Modify

Opened 5 years ago

Closed 4 years ago

#4565 closed defect (duplicate)

Creating first review fails

Reported by: stodge Owned by: mikechml
Priority: normal Component: PeerReviewPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

Fresh install of Trac-0.11.2.1, user has the correct permissions. Python 2.4.3 on Centos 5.2.

Trac detected an internal error:

OperationalError: ERROR: null value in column "idreview" violates not-null constraint

File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/web/main.py", line 432, in _dispatch_request
  dispatcher.dispatch(req)
File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/web/main.py", line 204, in dispatch
  resp = chosen_handler.process_request(req)
File "build/bdist.linux-x86_64/egg/codereview/peerReviewNew.py", line 137, in process_requestFile "build/bdist.linux-x86_64/egg/codereview/peerReviewNew.py", line 177, in createCodeReviewFile "build/bdist.linux-x86_64/egg/codereview/CodeReviewStruct.py", line 50, in saveFile "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/db/util.py", line 51, in execute
  return self.cursor.execute(sql)
File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/db/util.py", line 51, in execute
  return self.cursor.execute(sql)
File "/usr/lib64/python2.4/site-packages/pyPgSQL/PgSQL.py", line 3111, in execute
  raise OperationalError, msg
System Information:

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Chrome/1.0.154.43 Safari/525.19

Trac:	0.11.2.1
Python:	2.4.3 (#1, May 24 2008, 13:57:05) [GCC 4.1.2 20070626 (Red Hat 4.1.2-14)]
setuptools:	0.6c7
pyPgSQL:	2.5.1
Genshi:	0.5
mod_python:	3.2.8
Subversion:	1.5.1 (r32289)
jQuery:	1.2.6

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by stodge

Looks like it's already fixed in toddler (2.1?). Sorry, this must be a duplicate then.

comment:2 Changed 4 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from new to closed

comment:3 Changed 4 years ago by rjollos

  • Description modified (diff)

comment:4 Changed 4 years ago by rjollos

  • Description modified (diff)

Appears to be a duplicate of #3482.

comment:5 Changed 4 years ago by rjollos

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:6 Changed 4 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from reopened to closed

Closing with correct status, Duplicate.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mikechml. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.