Modify

Opened 5 years ago

Closed 4 years ago

#4731 closed defect (fixed)

Local File Playback

Reported by: anonymous Owned by: lcordier
Priority: normal Component: MovieMacro
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I couldn't get local file playback working as documented. I made the following changes to get it working:

(Forgive my ignorance in making diffs, pushing changes, and whatnot; the change is pretty small anyway)

/movie/Macro.py, ln. 40:

return '/' + '/'.join(parts)

... to ...

return '/'.join(parts)

Then you can reference the local file using the following syntax:

[[Movie(htdocs:/site/filename.flv)]]

Please take a look at this; if my changes are correct (they work for me!), then you should update your docs page & code.

Attachments (0)

Change History (6)

comment:1 follow-up: Changed 5 years ago by lcordier

It doesn't make sense, the function generates an absolute URL, one that starts with a '/'.
If you remove the first slash it is not an absolute URL anymore.
It works for me as is. When I get time, I'll add some debugging code to the macro, then we can test what is going on.

comment:2 in reply to: ↑ 1 Changed 5 years ago by john.berntsen@…

Replying to lcordier:

It doesn't make sense, the function generates an absolute URL, one that starts with a '/'.
If you remove the first slash it is not an absolute URL anymore.
It works for me as is. When I get time, I'll add some debugging code to the macro, then we can test what is going on.

After installing this on trac 0.11.3 i had the same problem, and this solution fixed it for me.

Regards - John Berntsen

comment:3 Changed 5 years ago by eppa

Same change to code worked for me as well (0.11.3)

Trac:		0.11
Python: 	2.5.2 (r252:60911, Oct 5 2008, 19:42:18) [GCC 4.3.2]
setuptools: 	0.6c8
SQLite: 	3.5.9
pysqlite: 	2.4.1
Genshi: 	0.5
mod_python: 	3.3.1
Pygments: 	0.9
Subversion: 	1.5.1 (r32289)
jQuery:		1.2.3

comment:4 Changed 5 years ago by tom.korn.mod@…

For me it works too.

Thanks

Tom Korn

comment:5 Changed 4 years ago by webPragmatist

Works for me too. I can confirm that it creates a path with chrome for the jwplayer and other assets.

comment:6 Changed 4 years ago by lcordier

  • Resolution set to fixed
  • Status changed from new to closed

(In [7771]) Closes #4731.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from lcordier. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.