Modify

Opened 5 years ago

Closed 4 years ago

#4771 closed enhancement (duplicate)

could the cloud be a popup tip-like window?

Reported by: jevans Owned by: obs
Priority: normal Component: LoomingCloudsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Instead of always taking up space in the ticket window, would it be possible to only show the cloud in a popup when the keywords field is active or when hovering over the field?

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 5 years ago by anonymous

We have done the following to make large tag clouds less intrusive in tickets:

loomingclouds.py add:

from genshi.builder import Element

stream |= Transformer( "//ul[@class='tagcloud']" ).wrap( Element('div',class_='tagclouddiv') )

tagcloud.css add (modify as required):

.tagclouddiv {
        height: 200px;
        width: 250px;
        background: #f7f7f7; 
        border: 1px solid #d7d7d7;
        margin: 5px 5px 2px 2px;
        padding: .25em; 
        overflow: auto
}

comment:2 in reply to: ↑ 1 Changed 5 years ago by k0s

Replying to anonymous:

We have done the following to make large tag clouds less intrusive in tickets:

loomingclouds.py add:

from genshi.builder import Element

stream |= Transformer( "//ul[@class='tagcloud']" ).wrap( Element('div',class_='tagclouddiv') )

tagcloud.css add (modify as required):

.tagclouddiv {
        height: 200px;
        width: 250px;
        background: #f7f7f7; 
        border: 1px solid #d7d7d7;
        margin: 5px 5px 2px 2px;
        padding: .25em; 
        overflow: auto
}

Sadly, this will make things worse for a small number of tags.

comment:3 Changed 4 years ago by obs

  • Owner changed from k0s to obs

comment:4 Changed 4 years ago by obs

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4812 the box is now limited to 40px but can be expanded on clicking a link

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from obs. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.