Modify

Opened 5 years ago

Closed 5 years ago

#4842 closed defect (duplicate)

post_process_request does not correctly pass content type

Reported by: anonymous Owned by: clp
Priority: high Component: AccountLdapPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

AccountLdapPlugin blocks other plugins from changing the content type of their response. This was a problem for me and kept RevtreePlugin from rendering its SVG.

Here's a patch that fixes it:

  • accountldap/accountldap.py

     
    5353 
    5454    def post_process_request(self, req, template, data, content_type): 
    5555        if not req.remote_user or req.session.has_key('email'): 
    56             return template, data, None 
     56            return template, data, content_type 
    5757        uid = req.remote_user.lower() 
    5858        name, email = self._getUserAttributes(uid) 
    5959        req.session['name'] = name 
    6060        req.session['email'] = email 
    61         return template, data, None 
     61        return template, data, content_type 
    6262    # 
    6363    #----------------------------------------- INavigationContributor interface 
    6464    # 

This issue was a blocker for our new install.

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by onecreativenerd

  • Resolution set to duplicate
  • Status changed from new to closed

sorry! forgot to log in!

duplicate of #4843

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from clp. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.