Modify

Opened 5 years ago

Closed 3 years ago

#5162 closed enhancement (wontfix)

Add a TICKET_COMMENT_CHANGE permission

Reported by: kontakt at meitzner dot net Owned by: rjollos
Priority: normal Component: TicketChangePlugin
Severity: normal Keywords:
Cc: rickm@… Trac Release: 0.11

Description

In 0.11.4 the "Change" link is only shown for users with TICKET_ADMIN or TRAC_ADMIN privileges, but as far as I've understood the purpose of the Plugin it should appear for unprivileged users at least with their own comments or changes to a ticket. Am I getting something wrong here?

I'd be glad if someone could verify this with a rather clean install of Trac 0.11.4, since I have a lot of plugins installed and enabled in my install. Just to make sure this defect is not caused by some interference with another plugin.

Please feel free to e-mail me if you need further information.

Cheerz, Martin

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by anonymous

  • Summary changed from Change Link ist only shown for users having ADMIN privileges to Change Link list only shown for users having ADMIN privileges

comment:2 Changed 5 years ago by anonymous

  • Summary changed from Change Link list only shown for users having ADMIN privileges to Change Link is only shown for users having ADMIN privileges

comment:3 Changed 5 years ago by rjollos

The behavior I'm seeing is that the Change link is only shown for users with TICKET_ADMIN privilege (and this would surely extend to users with TRAC_ADMIN priviledge as well). This seems consistent with the description on the wiki page as well.

User who have TICKET_ADMIN permissions will see the Change button
for each comment in the Change History of the ticket view.

comment:4 Changed 5 years ago by rjollos

  • Summary changed from Change Link is only shown for users having ADMIN privileges to Add a TICKET_COMMENT_CHANGE permission
  • Type changed from defect to enhancement

Changing this ticket to an enhancement for a TICKET_COMMENT_CHANGE permission.

comment:5 Changed 4 years ago by rjollos

  • Owner changed from SergeiLuchko to rjollos
  • Status changed from new to assigned

comment:6 Changed 3 years ago by sailorickm

  • Cc rickm@… added

comment:7 Changed 3 years ago by rjollos

  • Resolution set to wontfix
  • Status changed from assigned to closed

Closing as wontfix since the plugin has been deprecated. The permission is now available in the Trac core with Trac 0.12: t:TracPermissions#TicketSystem.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.