Modify

Opened 6 years ago

Closed 5 years ago

#5192 closed defect (fixed)

Auto complete does not work although installed successfully

Reported by: anonymous Owned by: k0s
Priority: normal Component: AutocompleteUsersPlugin
Severity: blocker Keywords:
Cc: eng.amr.noaman@… Trac Release: 0.11

Description

I'm working on a windows xp machine. Here is the logs of the installation. Every things seems ok.

D:\Python25>python setup.py install running install running bdist_egg running egg_info writing AutocompleteUsers.egg-info\PKG-INFO writing top-level names to AutocompleteUsers.egg-info\top_level.txt writing dependency_links to AutocompleteUsers.egg-info\dependency_links.txt writing entry points to AutocompleteUsers.egg-info\entry_points.txt reading manifest file 'AutocompleteUsers.egg-info\SOURCES.txt' writing manifest file 'AutocompleteUsers.egg-info\SOURCES.txt' installing library code to build\bdist.win32\egg running install_lib running build_py creating build\bdist.win32\egg creating build\bdist.win32\egg\autocompleteusers copying build\lib\autocompleteusers\autocompleteusers.py -> build\bdist.win32\eg g\autocompleteusers creating build\bdist.win32\egg\autocompleteusers\htdocs creating build\bdist.win32\egg\autocompleteusers\htdocs\css copying build\lib\autocompleteusers\htdocs\css\autocomplete.css -> build\bdist.w in32\egg\autocompleteusers\htdocs\css creating build\bdist.win32\egg\autocompleteusers\htdocs\js copying build\lib\autocompleteusers\htdocs\js\autocomplete.js -> build\bdist.win 32\egg\autocompleteusers\htdocs\js copying build\lib\autocompleteusers\htdocs\js\autocomplete_newticket.js -> build \bdist.win32\egg\autocompleteusers\htdocs\js copying build\lib\autocompleteusers\htdocs\js\autocomplete_newticket_cc.js -> bu ild\bdist.win32\egg\autocompleteusers\htdocs\js copying build\lib\autocompleteusers\htdocs\js\autocomplete_ticket.js -> build\bd ist.win32\egg\autocompleteusers\htdocs\js copying build\lib\autocompleteusers\htdocs\js\autocomplete_ticket_cc.js -> build \bdist.win32\egg\autocompleteusers\htdocs\js copying build\lib\autocompleteusers\htdocs\js\format_item.js -> build\bdist.win3 2\egg\autocompleteusers\htdocs\js copying build\lib\autocompleteusers\init.py -> build\bdist.win32\egg\autocom pleteusers byte-compiling build\bdist.win32\egg\autocompleteusers\autocompleteusers.py to a utocompleteusers.pyc byte-compiling build\bdist.win32\egg\autocompleteusers\init.py to init.p yc creating build\bdist.win32\egg\EGG-INFO copying AutocompleteUsers.egg-info\PKG-INFO -> build\bdist.win32\egg\EGG-INFO copying AutocompleteUsers.egg-info\SOURCES.txt -> build\bdist.win32\egg\EGG-INFO

copying AutocompleteUsers.egg-info\dependency_links.txt -> build\bdist.win32\egg \EGG-INFO copying AutocompleteUsers.egg-info\entry_points.txt -> build\bdist.win32\egg\EGG -INFO copying AutocompleteUsers.egg-info\not-zip-safe -> build\bdist.win32\egg\EGG-INF O copying AutocompleteUsers.egg-info\top_level.txt -> build\bdist.win32\egg\EGG-IN FO creating 'dist\AutocompleteUsers-0.4.1-py2.5.egg' and adding 'build\bdist.win32\ egg' to it removing 'build\bdist.win32\egg' (and everything under it) Processing AutocompleteUsers-0.4.1-py2.5.egg creating d:\python25\lib\site-packages\AutocompleteUsers-0.4.1-py2.5.egg Extracting AutocompleteUsers-0.4.1-py2.5.egg to d:\python25\lib\site-packages Adding AutocompleteUsers 0.4.1 to easy-install.pth file

Installed d:\python25\lib\site-packages\autocompleteusers-0.4.1-py2.5.egg Processing dependencies for AutocompleteUsers==0.4.1 Finished processing dependencies for AutocompleteUsers==0.4.1


The plugin appears correctly in trac, and it shows that it is enabled. I also checked in the trac.ini file and is shows the following under the components section:

autocompleteusers.autocompleteusers.autocompleteusers = enabled

is there anything missing? I tried to run trac on IE and on google chrome but both do not show the names in the cc.

Please help.

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by eng.amr.noaman@…

  • Cc eng.amr.noaman@… added; anonymous removed

comment:2 Changed 6 years ago by anonymous

  • Cc eng.amr.noaman@… added; eng.amr.noaman@… removed

comment:3 Changed 6 years ago by chrisheller

If it shows up as installed properly, then you can a) check the trac logs for any messages when you would be doing the auto-complete, and b) try using it on Firefox and watch it's error console for any javascript errors that may occur.

comment:4 Changed 5 years ago by ThurnerRupert

  • Resolution set to fixed
  • Status changed from new to closed

does [6288] solve it? if not reopen pls.

Add Comment

Modify Ticket

Action
as closed The owner will remain k0s.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.