Modify

Opened 5 years ago

Closed 5 years ago

#5324 closed defect (invalid)

SVN auth : passwd or htpasswd file ?

Reported by: postb99 Owned by: pacopablo
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: svnserve
Cc: Trac Release: 0.11

Description

Hello,

Sorry for filling a ticket but this may be helpful for other people to read the whole thing here. When things will be clear, I think I will update the wiki if it is relevant.

I've setup Trac 0.11.4 with AccountManagerPlugin and am confused by the following : when using SVN integration, one must provide the path of a password file.

The following works, the password file contains cleartext passwords :

[account-manager]
password_file = C:\Repositories\svn\Redcats_Ecocat\conf\passwd
password_store = SessionStore,SvnServePasswordStore

The following does not works (MissingSectionHeaderError: File contains no section headers), the password file contains md5 hashed passwords :

[account-manager]
password_file = C:\Repositories\htpasswd
password_store = SessionStore,SvnServePasswordStore

So I feel confused because the SVN server I use (either VisualSVN, or SVN + USVN) use the second file, while Trac successfully uses the first file. So this means 2 files to maintain, right ?

Is my issue related to some missing svnserve configuration ?

Thanks for some light.

Barbara

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by postb99

  • Resolution set to invalid
  • Status changed from new to closed

Closing this ticket as it is not a bug but a misunderstanding of SVN server working capabilities : either in svnserve mode (required by Trac, passwords in cleartext), or httpd mode (the way I have it setup). Refer to SVN book to have details :)

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from pacopablo. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.