Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5560 closed defect (worksforme)

Name of target project needed in change description text

Reported by: boftx@… Owned by: k0s
Priority: normal Component: TicketMoverPlugin
Severity: major Keywords:
Cc: boftx@… Trac Release: 0.11

Description

The name of the project to which a ticket was moved needs to be in the change log text. The current text does not include this item and it is a major ommission from what is otherwise a very useful module for multi-projects.

Ideally, the new ticket ID would be a link.

Changed 65 minutes ago by jim ¶
  ■ status changed from new to closed 
  ■ resolution set to moved 
    moved to /ticket/10

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by k0s

The full url of the project should be displayed if you have

[trac]
base_url =

set correctly

comment:2 follow-up: Changed 5 years ago by boftx@…

Does "base_url" need to be in a per project .ini file instead of the inherited .ini file? I placed the following in my common .ini file (example.com is faked):

    base_url = http://trac.example.com

and the resulting text in the ticket that I moved (on the original project) is:

Changed 19 seconds ago by jim ¶
  ■ resolution changed from fixed to moved 
    moved to  http://trac.example.com/ticket/11

I would expect to see, expecially since the name of the target project is already available in the list of targets:

Changed 19 seconds ago by jim ¶
  ■ resolution changed from fixed to moved 
    moved to  http://trac.example.com/PROJECT/ticket/11

The text of the resulting ticket on the target machine is fine, showing the origin ticket and URL.

comment:3 in reply to: ↑ 2 Changed 5 years ago by k0s

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to boftx@hotmail.com:

Does "base_url" need to be in a per project .ini file instead of the inherited .ini file? I placed the following in my common .ini file (example.com is faked):

    base_url = http://trac.example.com

and the resulting text in the ticket that I moved (on the original project) is:

Changed 19 seconds ago by jim ¶
  ■ resolution changed from fixed to moved 
    moved to  http://trac.example.com/ticket/11

I would expect to see, expecially since the name of the target project is already available in the list of targets:

Changed 19 seconds ago by jim ¶
  ■ resolution changed from fixed to moved 
    moved to  http://trac.example.com/PROJECT/ticket/11

The text of the resulting ticket on the target machine is fine, showing the origin ticket and URL.

Yes, this is how base_url works, which is to say that it must be specified on a per project basis. I agree that the behavior is less than desirable and advise ticketing on trac.edgewall.org

comment:4 Changed 5 years ago by boftx@…

Confirmed, providing a value for "base_url" in each project's individual trac.ini file works as expected. Thanks for the insight. Opening a ticket on the Trac site to suggest that "base_url" be populated as part of the initenv command as that is when trac.ini is created with an empty "base_url" and trac-admin already has logic to handle inherited options.

Add Comment

Modify Ticket

Action
as closed The owner will remain k0s.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.