Modify

Opened 5 years ago

Closed 4 years ago

#5887 closed defect (duplicate)

Ticket stats failing to start

Reported by: princesseryane Owned by: echo0101
Priority: highest Component: TracTicketStatsPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

I get the following error when i click on ticket stat tab

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/web/api.py", line 377, in send_error
    'text/html')
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/web/chrome.py", line 727, in render_template
    req.chrome[type_].append(
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/web/api.py", line 195, in __getattr__
    value = self.callbacks[name](self)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/web/chrome.py", line 488, in prepare_request
    for category, name, text in contributor.get_navigation_items(req):
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/ticket/web_ui.py", line 163, in get_navigation_items
    if 'TICKET_CREATE' in req.perm:
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/web/api.py", line 195, in __getattr__
    value = self.callbacks[name](self)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/web/main.py", line 262, in _get_perm
    return PermissionCache(self.env, self.authenticate(req))
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/web/main.py", line 134, in authenticate
    authname = authenticator.authenticate(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/web/auth.py", line 70, in authenticate
    authname = self._get_name_for_cookie(req, req.incookie['trac_auth'])
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/web/auth.py", line 189, in _get_name_for_cookie
    (cookie.value, req.remote_addr))
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/db/util.py", line 59, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/db/util.py", line 59, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
InternalError: ERREUR:  la transaction est annulée, les commandes sont ignorées jusqu'à la fin du bloc
de la transaction

Am I missing something?

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by princesseryane

  • Priority changed from high to highest
  • Summary changed from Error with Ticket stats to Ticket stats failing to start

my python traceback

Traceback (most recent call last):

File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/web/main.py", line 445, in _dispatch_request

dispatcher.dispatch(req)

File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/web/main.py", line 206, in dispatch

resp = chosen_handler.process_request(req)

File "/var/trac/esp/plugins/Tracticketstats-2.1-py2.5.egg/ticketstats/ticketstats.py", line 196, in process_request

last_num_open = self._get_num_open_tix(last_date, milestone, req)

File "/var/trac/esp/plugins/Tracticketstats-2.1-py2.5.egg/ticketstats/ticketstats.py", line 114, in _get_num_open_tix

cursor.execute("SELECT t.type AS type, owner, status, time AS created FROM ticket t, enum p WHERE p.name = t.priority AND p.type = 'priority' AND created <= %s %s" % (to_timestamp(at_date), ma_milestone_str))

File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/db/util.py", line 60, in execute

return self.cursor.execute(sql)

File "/usr/lib/python2.5/site-packages/Trac-0.11.6stable_r8560-py2.5.egg/trac/db/util.py", line 60, in execute

return self.cursor.execute(sql)

ProgrammingError: ERREUR: la colonne « created » n'existe pas LINE 1: ...E p.name = t.priority AND p.type = 'priority' AND created <=...

ProgrammingError: ERREUR: la colonne « created » n'existe pas LINE 1: ...E p.name = t.priority AND p.type = 'priority' AND created <=...

2009-09-29 16:08:45,365 Trac[chrome] DEBUG: Prepare chrome data for request

comment:2 Changed 4 years ago by rjollos

  • Description modified (diff)

Wrapped traceback in a code block to improve readability.

comment:3 Changed 4 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5626.

Add Comment

Modify Ticket

Action
as closed The owner will remain echo0101.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.