Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6190 closed defect (wontfix)

Hours tab not present - plugin probably doesn't load

Reported by: shubham_chakraborty@… Owned by: k0s
Priority: normal Component: TracHoursPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

I do not get the Hours tab in the tab list in my Trac.

System Information
Trac: 0.11
Python: 2.5.4 (r254:67916, Dec 23 2008, 15:10:54) [MSC v.1310 32 bit (Intel)]
setuptools: 0.6c9
MySQL: server: "4.1.22-community-nt", client: "5.0.27", thread-safe: 1
MySQLdb: 1.2.2
Genshi: 0.5.1
mod_python: 3.3.1
CustomFieldAdmin: 0.2.2
jQuery: 1.2.3

here is my system information.
I have installed many other plugins, edited the INI though this plugin doesnt even show up installed on the installed plugin list...is there a limit to no. of plugins installed?

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by k0s

  • Priority changed from high to normal
  • Summary changed from Hours tab not present to Hours tab not present - plugin probably doesn't load

if the hours tab isn't present, then the plugin probably isn't enabled. Did you try installing from egg? I'd recommend doing easy_install or downloading and doing python setup.py (develop|install), as the egg won't pull in the required dependencies.

If problems persist, please post the log showing where the plugin is attempted to load but fails. Without this information, it is impossible to diagnose.

comment:2 Changed 5 years ago by shubham_chakraborty@…

i downloaded the zip, extracted it,
Console cmd prompt: cd /pathname

: python setup.py bdist_egg

Then install the egg via the admin interface!!!
upon pressing the install button, nothing happens !!

2009-11-11 17:22:37,023 Trac[ticket_policy] DEBUG: Internal: action:DISCUSSION_ADMIN, user:shubham123, resource:None, perm: <trac.perm.PermissionCache object at 0x04388058>
2009-11-11 17:22:37,023 Trac[web_ui] INFO: Installing plugin TracHoursPlugin-0.3.3-py2.5.egg
2009-11-11 17:22:37,039 Trac[web_ui] INFO: Plugin TracHoursPlugin-0.3.3-py2.5.egg installed to C:/temp2/trac\plugins\TracHoursPlugin-0.3.3-py2.5.egg
2009-11-11 17:22:37,101 Trac[main] DEBUG: 97 unreachable objects found.
2009-11-11 17:22:38,052 Trac[env] INFO: Reloading environment due to configuration change
2009-11-11 17:22:38,193 Trac[loader] DEBUG: Adding plugin CalendarPopUp 0.0.2 from c:\temp2\trac\plugins\calendarpopup-0.0.2-py2.5.egg
............
......
2009-11-11 17:22:38,209 Trac[loader] DEBUG: Adding plugin TracMasterTickets 2.1.3 from c:\temp2\trac\plugins\tracmastertickets-2.1.3-py2.5.egg
2009-11-11 17:22:38,209 Trac[loader] DEBUG: Skipping "TracHoursPlugin 0.3.3": ("ComponentDependencyPlugin" not found)

But i have installed both ComponentDependency and TicketSidebar plugin!!!

comment:3 follow-up: Changed 5 years ago by anonymous

I found out the error..its dependecny on feedparser and dateutil...
the problem is its not able to download it via the console or eas_install..
however..i have downloaded the feedparser.py and .egg files....
can you direct me as to where to put these so that it'll work..

If there is any onther solution, please base it on the fact that i am not able to download anything from internet via the console(corporate policy)

comment:4 in reply to: ↑ 3 Changed 5 years ago by k0s

  • Resolution set to wontfix
  • Status changed from new to closed

Replying to anonymous:

I found out the error..its dependecny on feedparser and dateutil...
the problem is its not able to download it via the console or eas_install..
however..i have downloaded the feedparser.py and .egg files....
can you direct me as to where to put these so that it'll work..

If there is any onther solution, please base it on the fact that i am not able to download anything from internet via the console(corporate policy)

I don't think there is. The problem with the eggs is that they don't include dependency information. I don't know how to get around your corporate policy (except writing a Trac plugin that gives console access TTW)

comment:5 follow-up: Changed 5 years ago by anonymous

well...can i copy paste the required files...and then can it work or does it need to be installed ?
When it says searching for FeedParser, can i include it in any directory so that it will find it??

comment:6 in reply to: ↑ 5 Changed 5 years ago by k0s

Replying to anonymous:

well...can i copy paste the required files...and then can it work or does it need to be installed ?
When it says searching for FeedParser, can i include it in any directory so that it will find it??

I don't know I don't use egg files, I install via python setup.py or easy_install the old fashioned way

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.