Modify

Opened 5 years ago

Closed 4 years ago

#6274 closed defect (duplicate)

UnicodeDecodeError on UTF-8 encoded filenames

Reported by: josef Owned by: hvr
Priority: normal Component: GitPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I'm using the Debian/lenny packages of trac (0.11.1-2.1) and trac-git (0.0.20080710-3) for the Trac instance at http://serviceplatform.org:8000/trac/browser/admin.

Browsing most directories work fine. However, there are some like the prepared "testarea" subdirectory which contain non-ASCII filenames encoded in UTF-8. I see some mention of unicode() in the GitPlugin files but cannot really see where the fix would belong.

This is the error message in case the site is unreachable:

Trac detected an internal error:
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd1 in position 15: ordinal not in range(128)

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by hvr

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #5357

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hvr. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.