Modify

Opened 5 years ago

Closed 12 months ago

Last modified 12 months ago

#6328 closed defect (fixed)

Error during loading of plugin

Reported by: anonymous Owned by: rjollos
Priority: normal Component: MultipleWorkflowPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

The debug log shows the following information:

2009-12-14 12:05:27,823 Trac[loader] DEBUG: Loading MultipleWorkflowPlugin from d:\daten\trac\projekte\ish\plugins\multipleworkflowplugin-1.0-py2.5.egg
2009-12-14 12:05:27,823 Trac[loader] ERROR: Skipping "MultipleWorkflowPlugin = MultipleWorkflowPlugin": (can't import "ImportError: No module named MultipleWorkflowPlugin")

I installed the plugin using the admin page=>plugins=>install plugin. When I install it again, I get the message "already installed": I activated the plugin in the trac.ini as shown in the example...

Enable the plugin with:

[components]
multipleworkflowplugin.* = enabled
multipleworkflowplugin.multipleworkflowplugin.multipleworkflowplugin = enabled

Add the controller to the workflow controller list:

[ticket]
workflow=MultipleWorkflowPlugin

For using it you should have in the trac.ini file the [ticket-workflow] session because when a section for a ticket type doesn't exist trac uses the [ticket-workflow] for the actions to do. If you want to define different workflows than you should create in trac.ini sections called [ticket-workflow-ticket_type] where ticket_type is the type of ticket you want to use this section,you can create all the sections you want and trac will use them when that kind of ticket is being used,you can create ticket type in the admin panel under ticket types.

Any idea, what I did wrong?

Kind regards, Andreas

I am using Trac 0.11.6

Attachments (0)

Change History (14)

comment:1 Changed 5 years ago by rickert@…

Sorry, forgot my email address...

comment:2 follow-up: Changed 12 months ago by juha.simola@…

I have the same problem.

Did anyone find a solution for this?

comment:3 Changed 12 months ago by rjollos

  • Description modified (diff)

comment:4 in reply to: ↑ 2 ; follow-up: Changed 12 months ago by rjollos

  • Owner changed from ermal to rjollos
  • Status changed from new to assigned

Replying to juha.simola@…:

I have the same problem.

Did anyone find a solution for this?

Which version of Trac are you running?

comment:5 in reply to: ↑ 4 ; follow-ups: Changed 12 months ago by juha.simola@…

Replying to rjollos:

Replying to juha.simola@…:

I have the same problem.

Did anyone find a solution for this?

Which version of Trac are you running?

Trac 0.11.7

I actually found a workaround by:

  • moving MultipleWorkflowPlugin.py and an empty __init__.py to a new sub-folder MultipleWorkflowPlugin as usually plugins have sub-folders for python files and
  • Editing setup.py: entry_points = { 'trac.plugins':['MultipleWorkflowPlugin=MultipleWorkflowPlugin.MultipleWorkflowPlugin'],}

Maybe the original issue is caused by the fact that setup.py and __init__.py are in the same folder?

The command I use when compiling the egg: python setup.py bdist_egg

comment:6 in reply to: ↑ 5 Changed 12 months ago by anonymous

Replying to juha.simola@…:

Replying to rjollos:

Replying to juha.simola@…:

I have the same problem.

Did anyone find a solution for this?

Which version of Trac are you running?

Trac 0.11.7

I actually found a workaround by:

  • moving MultipleWorkflowPlugin.py and an empty __init__.py to a new sub-folder MultipleWorkflowPlugin as usually plugins have sub-folders for python files and
  • Editing setup.py: entry_points = { 'trac.plugins':['MultipleWorkflowPlugin=MultipleWorkflowPlugin.MultipleWorkflowPlugin'],}

Maybe the original issue is caused by the fact that setup.py and __init__.py are in the same folder?

The command I use when compiling the egg: python setup.py bdist_egg

I use Python version 2.7.3 if it has something to do with this problem.

comment:7 in reply to: ↑ 5 Changed 12 months ago by rjollos

Replying to juha.simola@…:

Maybe the original issue is caused by the fact that setup.py and __init__.py are in the same folder?

That shouldn't be the case, see: multipleworkflowplugin/0.11@13463. The structure is:

  • setup.py
  • MultipleWorkflowPlugin
    • __init__.py
    • MultipleWorkflowPlugin.py

comment:8 Changed 12 months ago by rjollos

  • Resolution set to fixed
  • Status changed from assigned to closed

In 13464:

Fixes #6328:

  • Renamed 0.11 directory to trunk
  • Modified entry point
  • Replaced tabs with spaces, fixed indentation problems and converted dos line-endings to unix

comment:9 Changed 12 months ago by rjollos

In 13465:

Refs #6328: Part of [13464].

comment:10 Changed 12 months ago by rjollos

In 13466:

Removed empty directories that were not removed by git-svn in [13463]. Refs #6328.

comment:11 Changed 12 months ago by rjollos

There were a large number of problems with the plugin. I didn't test enough to be certain that every issue is fixed, but the most basic functionality seems to work. You'll need to reinstall from the SVN repository to get the latest changes.

comment:12 Changed 12 months ago by rjollos

Btw, you may be better off using TypedTicketWorkflowPlugin.

comment:13 Changed 12 months ago by juha.simola@…

Thanks you for your responses. I used the zipped source provided at https://trac-hacks.org/wiki/MultipleWorkflowPlugin. Most probably it was outdated, because the folder structure was different.

I'll check the TypedTicketWorkflowPlugin you suggested. Or maybe AdvancedTicketWorkflowPlugin would be more recent? Do you have an opinion?

comment:14 Changed 12 months ago by rjollos

The zip sources were outdated, so I removed the files and have updated the wiki page so that the download links point to the subversion repository.

I don't have any experience with the two plugins you mention, but they both seem to be used more often than this plugin. You may want to ask for opinions on the t:MailingList.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.