Modify

Opened 4 years ago

Closed 21 months ago

#6427 closed defect (fixed)

[Patch] When configuring a different workflow, autocomplete doesn't work on reassign

Reported by: MartinBeyer Owned by: rjollos
Priority: normal Component: AutocompleteUsersPlugin
Severity: minor Keywords: jquery
Cc: mitar Trac Release: 0.11

Description (last modified by rjollos)

because input fields with other names than action_reassign_reassign_owner are created. They seem all to end with reassign_owner, however. (didn't check that in the sources)

workaround:

replace in autocompleteusers\htdocs\js\autocomplete_ticket.js

$("#action_reassign_reassign_owner").autocomplete("../users", {

with:

`$("[id$=reassign_owner]").autocomplete("../users", { `

Attachments (1)

autocomplete_ticket.js.diff (517 bytes) - added by jholg 3 years ago.
Patch diff based on r9775

Download all attachments as: .zip

Change History (14)

comment:1 Changed 4 years ago by rjollos

  • Owner changed from k0s to rjollos

Changing ticket owner to be new maintainer.

comment:2 Changed 3 years ago by rjollos

  • Description modified (diff)
  • Keywords jquery added
  • Priority changed from normal to high

comment:3 Changed 3 years ago by rjollos

  • Summary changed from When configuring a different workflow, autocomplete doesn't work on reassign to [Patch] When configuring a different workflow, autocomplete doesn't work on reassign

comment:4 Changed 3 years ago by jholg

I can confirm this patch works for me (I'm currently running on r9775 of this plugin).

Relevant trac code is in trac/ticket/default_workflow.py (line numbers as of Trac 0.11.4):

    226         if 'set_owner' in operations:
    227             id = 'action_%s_reassign_owner' % action
    228             selected_owner = req.args.get(id, req.authname)

Attaching mercurial diff for this change based on r9775.

Changed 3 years ago by jholg

Patch diff based on r9775

comment:5 Changed 21 months ago by rjollos

  • Status changed from new to assigned

Mitar has this in his branch as well: fc124698af4b. I'm pulling in the changes now.

comment:6 Changed 21 months ago by rjollos

  • Cc mitar added

comment:7 Changed 21 months ago by rjollos

(In [11728]) Refs #6427: Enable autocomplete to work on reassign when a custom workflow is enabled.

Setting plugin version back to 0.4.2dev.

  • 0.4.2 will be the release for Trac 0.11.
  • 0.5.0 will be the release for Trac 0.12.

comment:8 Changed 21 months ago by rjollos

Ticket will be left open for feedback until 0.4.2/0.5.0 are released.

comment:9 follow-up: Changed 21 months ago by mitar

We have been using this (in my branch) for some time now and it works.

comment:10 in reply to: ↑ 9 Changed 21 months ago by rjollos

Replying to mitar:

We have been using this (in my branch) for some time now and it works.

Which version of Trac are you running?

comment:11 Changed 21 months ago by mitar

0.12.2 there.

comment:12 Changed 21 months ago by rjollos

  • Priority changed from high to normal

comment:13 Changed 21 months ago by rjollos

  • Resolution set to fixed
  • Status changed from assigned to closed

Fix is in the current dev version of the trunk and will be released with version 0.4.2 of the plugin.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.