Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6516 closed defect (fixed)

Checking a property doesn't enable its field

Reported by: fjruiz@… Owned by: CuriousCurmudgeon
Priority: normal Component: BatchModifyPlugin
Severity: major Keywords:
Cc: fjruiz@… Trac Release: 0.11

Description

Permissions are properly set, but when I check a property to batch-modify it, the field doesn't get enabled.

Besides, the Comment property always appears checked (and its field enabled)

Attachments (0)

Change History (8)

comment:1 follow-up: Changed 5 years ago by anonymous

I am also having this problem using BatchModifyPlugin 0.3 and Trac 0.11.5 running under Python 2.6.4 on Ubuntu 9.10. Tested with Firefox 3.0, 3.5; IE 7, 8. This essentially makes the plugin useless for us, as we installed it primarily to move arbitrary groups of tickets between milestones.

It worked perfectly with BatchModifyPlugin 0.2, Python 2.5, on Gentoo (that server is no longer running, so I cannot check what Trac version nor specific Gentoo version).

comment:2 in reply to: ↑ 1 Changed 5 years ago by anonymous

Replying to anonymous:

...we installed it primarily to move arbitrary groups of tickets between milestones.

Sorry, scratch this part from my previous comment - got confused which issue I was adding to.

comment:3 Changed 5 years ago by CuriousCurmudgeon

I am now seeing this problem on 0.12dev as well with Firefox 3.5.

comment:4 Changed 5 years ago by CuriousCurmudgeon

(In [7537]) refs #6516

  • This appears to be caused by a bug introduced in r7415. The jQuery selector used to find the element to enable when the checkbox is clicked was still using @.

comment:5 Changed 5 years ago by CuriousCurmudgeon

  • Owner changed from ashwin_phatak to CuriousCurmudgeon
  • Status changed from new to assigned

comment:6 Changed 5 years ago by CuriousCurmudgeon

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:7 Changed 5 years ago by gregmac

I confirm the fix r7537 works for me, and is somewhat related to #6466

comment:8 Changed 5 years ago by gregmac

By the way, amazing timing - I was just doing the same fix independently when I noticed this commit.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.