Modify

Opened 5 years ago

Closed 4 years ago

Last modified 15 months ago

#6466 closed defect (fixed)

[Fix] Checkboxes do not appear next to tickets

Reported by: tmitchell Owned by: CuriousCurmudgeon
Priority: normal Component: BatchModifyPlugin
Severity: normal Keywords: jquery
Cc: Trac Release: 0.11

Description

I recently upgraded Trac and reinstalled BatchModifyPlugin 0.11

Added TICKET_BATCH_MODIFY permissions and enabled the plugin.

The form appears at the bottom of the query page, but the checkboxes to select the applicable tickets do not appear.


Running Trac 0.11.5

Plugins installed:

  • TracGit 0.11.0.2
  • BatchModify 0.2.0

Ubuntu 9.10

See original feature: #998

Attachments (0)

Change History (20)

comment:1 Changed 5 years ago by tmitchell

Just saw another applicable ticket: #4268

Tested on Firefox 3.6, IE 8.0, and Chrome 3.0.195.38

comment:2 Changed 5 years ago by anonymous

I'm having this same problem. Worked perfectly for me with BatchModifyPlugin 0.2, Python 2.5, and Gentoo (can't provide Trac or Gentoo version - server is no longer running).

My environment:

  • Trac 0.11.5
  • BatchModifyPlugin 0.3.0
  • Ubuntu 9.10
  • Python 2.6.4
  • Firefox 3.0, 3.5; IE 7, 8

No other plugins were installed when this was found.

comment:3 follow-up: Changed 5 years ago by anonymous

Experiencing the same issue with Debian testing:

  • Trac 0.11.5
  • BatchModifyPlugin 0.3.0
  • Debian testing
  • Python 2.5.4
  • Firefox 3.5, Opera 10
  • Other plugins: authz-policy

The log reports some rights that are being checked when requesting a query, but the TICKET_BATCH_MODIFY permission is not being listed there...

comment:4 Changed 5 years ago by CuriousCurmudgeon

  • Status changed from new to assigned

I am looking into this problem, but have not found the cause yet. What I see right now is that it effects a wide range of browsers. Every major one except IE6 and Safari has been mentioned. It is also independent of OS and browser version.

Possible Causes:

  • JQuery is not being retrieved properly. The checkboxes are built client-side with JQuery. Please check of JQuery is being retrieved.
  • JQuery error. The most likely culprit looks to be when retrieving each id column from the query results. If your version of Trac does not return results for "table.listing tr td.id" then no checkboxes will be built. This seems unlikely, because I have seen this problem effect only some users using the same Trac instance.

comment:5 Changed 5 years ago by anonymous

I do see two messages in Firefox's Error Console, unsure if they're related to JQuery or not:

Warning: Expected attribute name or namespace but found '@for'.
Error: uncaught exception: Syntax error, unrecognized expression: [@for='groupdesc']

My Apache access log shows jquery.js being requested and served successfully (status 200). Opening it in my browser shows that it's JQuery v1.3.2 (Revision 6246).

comment:6 Changed 5 years ago by gregmac

The changes are caused by a change in jquery 1.3:

http://docs.jquery.com/Release:jQuery_1.3#Upgrading

The '@' in [@attr] has been removed. Deprecated since 1.2 this old syntax no longer works. Simply remove the @ to upgrade.

This was fixed in Trac 0.11.6 r8503.

I'm running a .deb package version, so I fixed it for 0.11.5 just by modifying /usr/lib/python2.6/dist-packages/trac/htdocs/js/trac.js as in the diff above.

comment:7 Changed 5 years ago by gregmac

Also, the fix in r7537 is required

comment:8 Changed 5 years ago by magnate

Hmmm. I am running Debian squeeze with trac 0.11.6-3, and I still do not see checkboxes in any of IE7, Firefox 3.5.8 or epiphany-browser (squeeze or sid versions). I am using plugin version 0.4.0, though I can't see the change in 0.4.1 making any difference. I have TICKET_BATCH_MODIFY permission.

In contrast to gregmac, /usr/lib/python2.6/dist-packages/trac does not exist for me. trac.js is in /usr/share/pyshared/trac/htdocs/js/, and the fix is already applied as I am running 0.11.6.

Grateful for any further things to check.

comment:9 Changed 5 years ago by magnate

P.S. jquery package is libjs-jquery, version 1.4.1-1. I *did* see checkboxes until a month or so ago.

comment:10 in reply to: ↑ 3 ; follow-up: Changed 5 years ago by anonymous

Replying to anonymous:
Checking back: The jquery hints pointed me towards a look into the Net panel of Firebug, showing that jquery.js yielded a 404. This fixed the checkboxes for me:

/usr/lib/python2.5/site-packages/trac/htdocs/js$ sudo ln -s /usr/share/pyshared/trac/htdocs/js/jquery.js

comment:11 in reply to: ↑ 10 Changed 5 years ago by anonymous

Replying to anonymous:

Replying to anonymous:
Checking back: The jquery hints pointed me towards a look into the Net panel of Firebug, showing that jquery.js yielded a 404. This fixed the checkboxes for me:

/usr/lib/python2.5/site-packages/trac/htdocs/js$ sudo ln -s /usr/share/pyshared/trac/htdocs/js/jquery.js

Coming back a last time: The above fix didn't work. Manually downgrading to jQuery 1.2 worked: Copying jQuery 1.2.6 to /usr/lib/python2.5/site-packages/trac/htdocs/js finally worked.

comment:12 Changed 5 years ago by AdrianFritz

  • Keywords jquery added
  • Summary changed from Checkboxes do not appear next to tickets to [Fix] Checkboxes do not appear next to tickets

Seems it's fixed.

comment:13 Changed 5 years ago by AdrianFritz

... with previous hints from anonymous.

comment:14 Changed 4 years ago by CuriousCurmudgeon

I am curious to see if those having this problem have any JQuery functionality in Trac. A quick way to test is to see if you can fold the filters section on the custom query page. If JQuery doesn't work anywhere then it is most likely a path problem. Downgrading JQuery shouldn't be necessary as the plugin no longer uses the deprecated selector syntax.

comment:15 follow-up: Changed 4 years ago by tmitchell

Paths were fine on my system, jquery and all the other js requirements downloaded fine. You were correct, however, there was no jquery functionality at all. The JS console showed the following error (on all pages I checked)

jquery.js@1642:
Uncaught Syntax error, unrecognized expression: [@for='groupdesc']

Downgrading to jquery-1.2.6 did indeed the problem. I have folding filters and checkboxes again!

comment:16 in reply to: ↑ 15 Changed 4 years ago by gregmac

Replying to tmitchell:

jquery.js@1642:
Uncaught Syntax error, unrecognized expression: [@for='groupdesc']

Downgrading to jquery-1.2.6 did indeed the problem. I have folding filters and checkboxes again!

See my comment above, two fixes are needed (to fix without downgrading jquery):

comment:17 Changed 4 years ago by CuriousCurmudgeon

  • Resolution set to fixed
  • Status changed from assigned to closed

As this is fixed using the latest release of Trac and batch_modify I am closing the ticket. If you are still having problems please check the path your browser is attempting to load JQuery from.

comment:18 Changed 4 years ago by AdrianFritz

Thanks.

comment:19 Changed 4 years ago by sue.sml2006@…

I am a relative newbie, but I think I'm having this jquery problem. How do I apply the changesets r8503 and r7537 to my trac installation? where is this trac.js file that needs the patch, because I cannot find it in my folders nor in the batchmodifyplugin.

comment:20 Changed 4 years ago by anonymous

with the help of my sysadmin we got the issue resolved. it was in fact the jquery problem.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.