Modify

Opened 5 years ago

Closed 4 years ago

#6609 closed defect (duplicate)

Declared features are not available.

Reported by: abekkine@… Owned by: mestudd
Priority: normal Component: ExtendedVersionPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

Roadmap like view, and milestone assignment features of the plugin (as seen on screenshots) does not exist on r7529 revision of the plugin. Only view in "version_roadmap.png" screenshot is working.

Python: 2.6.4rc2
Trac: 0.11.5-2ubuntu1
System: Ubuntu Server 9.10
Linux 2.6.31-14-generic-pae #48-Ubuntu SMP Fri Oct 16 15:22:42 UTC 2009 i686 GNU/Linux

Both tried with apache mod_python and tracd, result is the same. Below is the tracd output during accessing versions tab and first version link. And i should not forget to mention, there are some tickets assigned to milestones and those same version, too.
...
192.168.0.89 - - [10/Feb/2010 21:08:36] "GET /trac/versions HTTP/1.1" 200 -
192.168.0.89 - - [10/Feb/2010 21:08:36] "GET /trac/chrome/common/css/roadmap.css HTTP/1.1" 200 -
192.168.0.89 - - [10/Feb/2010 21:08:36] "GET /trac/chrome/site/your_project_logo.png HTTP/1.1" 404 -
192.168.0.89 - - [10/Feb/2010 21:08:59] "GET /trac/version/1.0 HTTP/1.1" 200 -
192.168.0.89 - - [10/Feb/2010 21:08:59] "GET /trac/chrome/extendedversion/css/extendedversion.css HTTP/1.1" 200 -
192.168.0.89 - - [10/Feb/2010 21:08:59] "GET /trac/chrome/site/your_project_logo.png HTTP/1.1" 404 -
...

Attachments (0)

Change History (5)

comment:1 follow-up: Changed 5 years ago by mestudd

  • Status changed from new to assigned

It's working for me, so I'm not sure what the problem is.
Did you edit a milestone and assign it to a version?
What configuration for the plugin do you have set in trac.ini?
Are you accessing as a regular user or admin? What are the permissions for the user (trac-admin /path/to/trac permissions list)?

comment:2 in reply to: ↑ 1 Changed 5 years ago by anonymous

Replying to mestudd:

It's working for me, so I'm not sure what the problem is.
Did you edit a milestone and assign it to a version?

How do i edit a milestone and assign it to a version? I assume that it will be performed in new ticket page automatically, whenever we assign both version and milestone to a ticket. Besides this, i couldn't find any other way to relate versions with milestones (in roadmap page, admin milestone page, or in versions page).

What configuration for the plugin do you have set in trac.ini?

[components]
extendedversionplugin.* = enabled

[extended_version]
roadmap_navigation = true
navigation_item = version
version_stats_provider = DefaultTicketGroupStatsProvider
milestone_stats_provide = DefaultTicketGroupStatsProvider

Are you accessing as a regular user or admin?

I've tried as both admin and regular user.

What are the permissions for the user (trac-admin /path/to/trac permissions list)?

This is for myself, as admin:

User      Action
---------------------------------
abekkine  BROWSER_VIEW
abekkine  CHANGESET_VIEW
abekkine  CONFIG_VIEW
abekkine  EMAIL_VIEW
abekkine  FILE_VIEW
abekkine  LOG_VIEW
abekkine  MILESTONE_ADMIN
abekkine  MILESTONE_CREATE
abekkine  MILESTONE_DELETE
abekkine  MILESTONE_MODIFY
abekkine  MILESTONE_VIEW
abekkine  PERMISSION_ADMIN
abekkine  PERMISSION_GRANT
abekkine  PERMISSION_REVOKE
abekkine  REPORT_ADMIN
abekkine  REPORT_CREATE
abekkine  REPORT_DELETE
abekkine  REPORT_MODIFY
abekkine  REPORT_SQL_VIEW
abekkine  REPORT_VIEW
abekkine  ROADMAP_ADMIN
abekkine  ROADMAP_VIEW
abekkine  SEARCH_VIEW
abekkine  TICKET_ADMIN
abekkine  TICKET_APPEND
abekkine  TICKET_CHGPROP
abekkine  TICKET_CREATE
abekkine  TICKET_EDIT_CC
abekkine  TICKET_EDIT_DESCRIPTION
abekkine  TICKET_MODIFY
abekkine  TICKET_VIEW
abekkine  TIMELINE_VIEW
abekkine  TRAC_ADMIN
abekkine  VERSION_ADMIN
abekkine  VERSION_CREATE
abekkine  VERSION_DELETE
abekkine  VERSION_MODIFY
abekkine  VERSION_VIEW
abekkine  WIKI_ADMIN
abekkine  WIKI_CREATE
abekkine  WIKI_DELETE
abekkine  WIKI_MODIFY
abekkine  WIKI_VIEW

and this for my test user (I first tried with only VERSION_VIEW, then added others later):

User    Action
-----------------------
tester  BROWSER_VIEW
tester  CHANGESET_VIEW
tester  FILE_VIEW
tester  LOG_VIEW
tester  MILESTONE_VIEW
tester  REPORT_SQL_VIEW
tester  REPORT_VIEW
tester  ROADMAP_VIEW
tester  SEARCH_VIEW
tester  TICKET_APPEND
tester  TICKET_CHGPROP
tester  TICKET_CREATE
tester  TICKET_MODIFY
tester  TICKET_VIEW
tester  TIMELINE_VIEW
tester  VERSION_ADMIN
tester  VERSION_CREATE
tester  VERSION_DELETE
tester  VERSION_MODIFY
tester  VERSION_VIEW
tester  WIKI_CREATE
tester  WIKI_MODIFY
tester  WIKI_VIEW

And thanks for both the job and the reply... :)

comment:3 Changed 5 years ago by anonymous

Hello again, i've found the reason why i can't assign milestones to versions;
Version combo in milestone edit does not appear for the milestones created before plugin was installed. However, when you create and edit new milestones; the version assignment box is available.

Unfortunately, when i choose version details after perform assignment, i get following error:

 Trac detected an internal error:
 AttributeError: qry_args

Python traceback:

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 444, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 205, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/extendedversion/version.py", line 124, in process_request
    return self._render_view(req, db, version)
  File "build/bdist.linux-i686/egg/extendedversion/version.py", line 288, in _render_view
    milestone_stats.append(milestone_stats_data(self.env, req, stat, milestone.name))
  File "/usr/lib/python2.6/dist-packages/trac/ticket/roadmap.py", line 287, in milestone_stats_data
    'stats_href': query_href(stat.qry_args),
  File "/usr/lib/python2.6/dist-packages/trac/web/api.py", line 198, in __getattr__
    raise AttributeError(name)
AttributeError: qry_args

comment:4 Changed 5 years ago by mestudd

D'oh! I made mistakes writing the installation/configuration instructions. The component is extendedversion, not extendedversionplugin. trac.ini should have:

[components]
extendedversion.* = enabled

You will then need to run trac-admin /path/to/trac upgrade

That doesn't make sense with you having the permissions or actually accessing the pages, so maybe you already figured that out.

How do i edit a milestone and assign it to a version? I assume that it will be performed in new ticket page automatically, whenever we assign both version and milestone to a ticket.

View the milestone and click the "Edit Milestone" button. There should be a dropdown for version between the name and schedule. Same for creating a new milestone.

The version field on tickets is not used by this plugin. It pulls the tickets assigned to the milestones assigned to version.

The permissions look sufficient for access to the extended version features.

Thanks for trying the plugin. You must be the first person, which is why you're having so many problems.

comment:5 Changed 4 years ago by mestudd

  • Resolution set to duplicate
  • Status changed from assigned to closed

Closing as a duplicate of #6764, as I think that's the only outstanding issue here. There's a patch in the other bug to try and debug what's happening.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.