Modify

Opened 4 years ago

Closed 4 years ago

#6965 closed enhancement (worksforme)

does undesired redirect in new side-by-side editor mode in trac-0.12

Reported by: hasienda Owned by: martin_s
Priority: normal Component: ServerSideRedirectPlugin
Severity: normal Keywords: side-by-side redirect
Cc: Trac Release: 0.12

Description

works well with trac-0.12 too, but has nasty side-effect in new side-by-side editor mode

  1. open wiki page with editor
  2. activate side-by-side editor mode, if not done before
  3. type valid redirect code, i.e.
    [[Redirect(WikiStart)]]
    
  4. stop typing for a second
  5. on live preview attempt redirect will happen, breaking out of editor mode

so a workaround is needed to make it play nicely with users of trac-0.12

tested with

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by hasienda

  • Resolution set to worksforme
  • Status changed from new to closed

While testing this with additional debug code inside tracserversideredirect/plugin.py I can't reproduce, but it does cleanly show the redirect info in side-by-side preview instead. Nice.

Maybe it was interference with TracRedirect Macro, or a special path? I'll close this and re-open, if I can reproduce. Sorry for the noise.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from martin_s. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.