Modify

Opened 5 years ago

Closed 3 years ago

#6966 closed defect (duplicate)

PDF creation does not work if image macro has no absolute links in it

Reported by: link@… Owned by: diorgenes
Priority: normal Component: TracWikiToPdfPlugin
Severity: normal Keywords: PDF, empty pages, solution, amelioration
Cc: Trac Release: 0.11

Description

Hello

My problem is actually not a defect. However, the solution I describe here might help others and/or could ameliorate this plugin. As to the other empty PDF problems: I experienced all the failures as you did, too.

By defining a "pathtocover" (in the main trac.ini, not an inherited one) variable and rewriting the path to the pic (as described further down) the W2PDF plugin did its job. But here is my question.

Picture this:

[[Image(FunnyLolCatPicture.jpg)]]

After laughing cordially you want to create a PDF from the wiki page which contains this picture. When you are me, that does not work.

Then, after trying to get it to work, you find out, that this:

[[Image(wiki:lolCatProject:FunnyLolCatPicture.jpg)]]

actually works. You can create a PDF with pictures in it.

Now my question: is it possible to change this plugin so it finds relative links? This would save us a good amount of time since we have a lot of wiki sites that need to be rendered to PDF... hopefully without the need to change the image macros.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4043.

Add Comment

Modify Ticket

Action
as closed The owner will remain diorgenes.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.