Modify

Opened 5 years ago

Closed 2 years ago

#7113 closed defect (wontfix)

TicketDeletePlugin breaks both Toolbar icons and MenusPlugin in "Create New Ticket"

Reported by: trachacks.vb2@… Owned by: coderanger
Priority: normal Component: TicketDeletePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

When creating new tickets, users with TRAC_ADMIN and TICKET_ADMIN rights will not see the wikitoolbar formatting icons (see also #trac4564).

Attachments (5)

TicketDeletePlugin disabled - MenusPlugin mainnav tab.png (19.9 KB) - added by dnedelchev 4 years ago.
view when TickedDeletePlugin? is disabled
TicketDeletePlugin enabled - broken MenusPlugin mainnav tab.png (15.0 KB) - added by dnedelchev 4 years ago.
view when TickedDeletePlugin is enabled
TicketDeletePlugin-enabled-broken-MenusPlugin-mainnav-tab.png (15.0 KB) - added by dnedelchev 4 years ago.
plugin enabled, mainnav bar broken (I try again with no spaces in the filename)
TicketDeletePlugin-disabled-MenusPlugin-mainnav-tab.png (19.9 KB) - added by dnedelchev 4 years ago.
plugin disabled, mainnav bar OK (reattach with no spaces in the filename)
patch-7113.txt (2.4 KB) - added by WouterVH 4 years ago.
Patch for ticketdelete

Download all attachments as: .zip

Change History (16)

comment:1 Changed 5 years ago by dfleming@…

On a freshly installed version of Trac I had no problems, but the above mentioned issue started occurring when I upgrade from a older version of Trac. Not sure which version the problem started but definitely > v 0.11

comment:2 Changed 4 years ago by olistudent

This problem occurs for my trac installation too. trac version is 0.11.7. TicketDeletePlugin is the actual revision. Any hints what to do? What information would be useful to fix this issue?

comment:3 Changed 4 years ago by anonymous

I'm not really sure if this helps, but the way this happens is pretty odd. When I go to create a new ticket the toolbar is gone. But if I create the ticket and go look at it the toolbar now appears. So it must be some sort of permissions initialization of sorts on New Ticket. That's all the info I have. Hope it helps.

comment:4 Changed 4 years ago by olistudent

The problem comes from ticketdelete.js and has to do with this inlinebuttons css style. I think it overrides something. ticketdelete.js and css are not needed when creating a ticket. Are they?

Is it easy to exclude this page?

comment:5 Changed 4 years ago by dnedelchev

  • Summary changed from TicketDeletePlugin breaks Toolbar icons to TicketDeletePlugin breaks both Toolbar icons and MenusPlugin in "Create New Ticket"

I've noticed another odd thing in the newticket page appearance. That could be related to this issue, so I decided not to create a new ticket for that.
When MenusPlugin is not enabled, the items of the main navigation bar are alligned right (default). Enabling MenusPlugin normally causes mainnav bar to become alligned left.
But when TicketDeletePlugin is also enabled, I see following anomaly:

When I press "New Ticket", the main nav. bar alignment returns to right and MenusPlugin ceases to work properly for that view too (while it's OK with any other view just like it happens to the edit toolbar icons).
When I disable TicketDeletePlugin all things return to their places - the main nav. bar is alligned to left for the "Create New Ticket" page too along with the reappeared toolbar icons.
(Thus I think I may postpone TicketDeletePlugin installation to our production trac-environmets for now - until it's fixed or at least until we'll promptly need tickets delete functionality.)

Note: Running Trac 0.11.7 / Apache / mod_wsgi

P.S. I prepared two screenshots but I don't see an "Attach" button.

Changed 4 years ago by dnedelchev

view when TickedDeletePlugin? is disabled

Changed 4 years ago by dnedelchev

view when TickedDeletePlugin is enabled

Changed 4 years ago by dnedelchev

plugin enabled, mainnav bar broken (I try again with no spaces in the filename)

Changed 4 years ago by dnedelchev

plugin disabled, mainnav bar OK (reattach with no spaces in the filename)

comment:6 Changed 4 years ago by dnedelchev

I'm sorry for the mess. I forget there should be no spaces in the filenames... The first two attached files are inaccessible so an admin can delete them.

comment:7 Changed 4 years ago by anonymous

The problem comes from ticketdelete.js

The problem is in the second line:

$(document).ready(function() {
    var ticket = /\/ticket\/(\d+)/.exec(document.location)[1];   <--

Changed 4 years ago by WouterVH

Patch for ticketdelete

comment:8 Changed 4 years ago by trachacks.vb2@…

Just noticed that ticket delete and comment delete functionality is included in 0.12 so there is no reason to install this plugin any longer and therefor no conflict :)

comment:9 Changed 4 years ago by olistudent

Not everybody can easily switch to 0.12. But WouterVH's patch fixed the problem for me. Thank you.

comment:10 Changed 2 years ago by rjollos

The JavaScript is being removed in #1749, which will most likely resolve this issue.

comment:11 Changed 2 years ago by rjollos

  • Resolution set to wontfix
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed The owner will remain coderanger.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.