Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7284 closed enhancement (duplicate)

updating tickets with xmlrpc in the name of a different user

Reported by: seniorsamu@… Owned by: osimons
Priority: normal Component: XmlRpcPlugin
Severity: normal Keywords: submitter
Cc: Trac Release: 0.11

Description

When a ticket is created using xmlrpc, the user can specify the reporter field so that a single user can be used from the calling program to do all ticket creation. However, when a change has to be introduced, this solution does not work, as with the ticket update xmlrpc call you cannot specify the changer. Implementing a small change in the plugin provides this capability.

In order to achieve this, we introduce an additional attribute to calling ticket.update. This is 'changer'. If the attribute is present then the changer will be logged as to who performed the change, otherwise the user who is authenticated. The attached patch introduces this change.

As this change does not affect current functionality, rather it adds further functions, I would be glad to see this change integrated into xmlrpc. However, didn't have a chance to check if this change affects any of the other extenstions working with xmlrpc, but as all current functionality remains I see little problem there.

Attachments (1)

ticket.patch (1.7 KB) - added by seniorsamu 4 years ago.
This patch has to be applied on ticket.py in the xmlrpc package

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by seniorsamu

This patch has to be applied on ticket.py in the xmlrpc package

comment:1 Changed 4 years ago by osimons

  • Resolution set to duplicate
  • Status changed from new to closed

This really is a duplicate of #5445, isn't it? That also has a patch. I'm closing this one and referring back here from the older ticket.

comment:2 Changed 4 years ago by seniorsamu

You are right. In fact, this is a duplicate of that defect. Thanks for pointing out.

Add Comment

Modify Ticket

Action
as closed The owner will remain osimons.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.