Modify

Opened 4 years ago

Closed 2 years ago

#7415 closed defect (worksforme)

No graph is displayed

Reported by: anonymous Owned by: coderanger
Priority: high Component: MasterTicketsPlugin
Severity: blocker Keywords:
Cc: cragusa@…, tanner.postert@… Trac Release: 0.11

Description

Installed the plugin, clicking on the depgraph link in the upper right corner, shows just

Dependency graph

without any actual graph

Attachments (0)

Change History (15)

comment:2 Changed 4 years ago by lukecyca

  • Summary changed from MasterTicketsPlugin to No graph is displayed

We'll need more details.

  • Have you tried more than one ticket? Have you tried tickets with different configurations of blocking/blockedby tickets listed on them?
  • Is your mastertickets database upgraded from a previous version, or is this a brand new install?
  • Is there anything relevant in the trac.log?

comment:3 Changed 4 years ago by Hal

I'm not the OP, but I have a similar issue. To answer your question:

  • I've tried multiple tickets
  • both working and non-working are upgraded databases
  • I don't see anything relevant in the log at debug level.

What version of GraphViz is required? I have the plugin working fine on my laptop, but no graph is generated on our production system.

software Laptop (working) Production (non-working)
TracMasterTicket 2.1.3 2.1.3
Trac 0.11.5 0.11.5rc1
Python 2.5.4 2.4.3
GraphViz dot - graphviz version 2.26.3 (20100126.1600) dot - Graphviz version 2.18 (Tue Mar 11 08:15:03 UTC 2008)
OS Darwin 10.4.0 (snow leopard) Linux 2.6.9-42.7.ELsmp (RHEL 4)

Everything else about the

comment:4 Changed 4 years ago by Hal

Everything else about the system is the same.

The plugin in both cases was built from the git repository at revision 99ef5f532aebb106cb6d50644c13400cab602ad0.

comment:5 Changed 4 years ago by anonymous

I'm the initial reporter of this error. I tried with different tickets, but always the same result. The installation of the masterticket is a new one, so the database is new. The trac.log shows this

2010-08-31 13:32:33,281 Trac[main] ERROR: [Errno 2] No such file or directory
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/web/main.py", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/mastertickets/web_ui.py", line 148, in process_request
  File "build/bdist.linux-x86_64/egg/mastertickets/graphviz.py", line 129, in render
  File "/usr/lib64/python2.4/subprocess.py", line 550, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.4/subprocess.py", line 993, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
2010-08-31 13:32:33,542 Trac[main] DEBUG: 705 unreachable objects found.

comment:6 Changed 4 years ago by anonymous

It looks to me that this is caused by an incorrect dot_path or gs_path.

In the console on your server, run which dot. Take note of the path returned. If none is returned, you probably need to install graphviz. In your trac.ini, add this:

[mastertickets]
dot_path=/opt/local/bin/dot

or whatever the path is on your machine. If you're using ghostscript, then you'll have to do the same with gs.

comment:7 follow-up: Changed 4 years ago by anonymous

i am not the op either but I am seeing the same behavior

the graph pages shows up, but with a broken link to the image.

trac.log just shows

2010-08-31 11:43:46,217 Trac[main] DEBUG: Dispatching <Request "GET u'/depgraph/3122/depgraph.png'">

no warnings or errors.

i have the dot path set in trac.ini as well.

trac version: 0.11.5 MasterTickets: 2.1.3 GraphViz: 2.26.3

comment:8 in reply to: ↑ 7 Changed 4 years ago by anonymous

Replying to anonymous:

i am not the op either but I am seeing the same behavior

Could you please go to http://<your-trac-instance>/depgraph/3122/depgraph.png and see what kind of output you get? If there is a traceback, please post that.

comment:9 Changed 4 years ago by anonymous

no trackback, the file just shows up as a broken link. It is a 0 byte image.

comment:10 Changed 4 years ago by anonymous

  • Cc tanner.postert@… added

comment:11 Changed 4 years ago by anonymous

also, failed to mention, i'm running Agile Trac as well, which may be breaking it.

comment:12 Changed 4 years ago by Hal

Found and fixed on my end - I have no idea if this is the issue for the other folks.

My problem was my default installation of GraphViz was not compiled with 'png' support. An older version (2.14) was available that did have 'png' support. Pointing explicitly to the other version fixed things.

Here's the test, and output for a non-usable GraphViz:

$ echo | /usr/bin/dot -Tpng && echo Works || echo Fails
Format: "png" not recognized. Use one of: canon cmap cmapx cmapx_np dia dot fig hpgl imap imap_np ismap mif mp pcl pic plain plain-ext ps ps2 svg svgz vml vmlz vtx xdot
Fails

For an instance that will work:

$ echo | ~/bin/dot -Tpng && echo Works || echo Fails
Works

comment:13 Changed 4 years ago by anonymous

that was the problem for me too.

I tried to use the --with-pnglibdir=DIR, but it still failed and said it was looking for png.h in config.log.

I downloaded and installed libpng-devel, recompiled and it works BEAUTIFULLY. thanks for the help.

comment:14 Changed 4 years ago by Hal

fwiw, I opened ticket:7621 to improve the error reporting for cases like this.

comment:15 Changed 4 years ago by anonymous

The package I use does not have the plugins configured (that is a good thing for most users do not need it). In this case it was necessary to run "dot -c" as root. The option was not described in the man file, but was revealed with "dot --help". While I clearly support the improvement of the error reporting requested with #7621, each solution described here is really a system configuration problem not directly tied to trac, therefore I would lower the severity to normal (first post here on this tracker, can't be doing that yet).

Note though that the test

$ echo | /usr/bin/dot -Tpng && echo Works || echo Fails

fails as such:

Format: "png" not recognized. Use one of: canon cmap cmapx cmapx_np dia dot fig hpgl imap imap_np ismap mif mp pcl pic plain plain-ext ps ps2 svg svgz vml vmlz vtx xdot
Fails

but the solution was not a recompile but rather a simple configuration command. That points towards an error reporting bug on dot's part as well.

comment:16 Changed 2 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from new to closed

Since we have #7621 to cover the trouble encountered in this ticket, I'm closing this as worksforme.

Add Comment

Modify Ticket

Action
as closed The owner will remain coderanger.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.