Modify

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#7416 closed defect (fixed)

URLs generated are wrong

Reported by: roger@… Owned by: qwp0
Priority: normal Component: ProgressMeterMacro
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

I use the ProgressMeter macro on a Trac 0.12 system to show the status of tickets in a milestone.

[[ProgressMeter(owner=$USER, milestone~=Wasabi)]]

The ticket counts and all are correct. However, the query URLs generated in the text displayed by the macro under the graphic are wrong:

http://www.somewhere.com/trac/query?owner=milestone&group=status&status=testing

This is the link that is generated for that part of the meter. In this case, I have logged in as me, so the user is 'roger'. The URL generated by the macro should have owner=roger. Not owner=milestone (the literal text 'milestone'). The "group=status" I am not sure about. The "status=testing" is correct.

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by qwp0

  • Resolution set to fixed
  • Status changed from new to closed

(In [8562]) ProgressMeterMacro/0.12: Fixed #7416, everything oughtta be OK now. Good night to all of ya!

comment:2 Changed 4 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

I just installed 8563, and I now get:

Error: Macro ProgressMeter(owner=$USER, milestone~=Wasabi) failed

Invalid input!

The problem seems to be when there is more than one parameter. This seems to work:

[[ProgressMeter(owner=$USER)]]

This worked before, except for the link problem. This is on a 0.12 release. I of course installed the 0.12 release version. I am running Python 2.5.

Roger Oberholtzer (roger@…)

comment:3 Changed 3 years ago by qwp0

  • Resolution set to fixed
  • Status changed from reopened to closed

The Invalid input! error message was probably caused by the bug described in #8763, not the multiple parameters supplied to the macro. Should be fixed now.

comment:4 Changed 3 years ago by anonymous

The update to the latest version did fix the problem for me. Thanks!

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from qwp0. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.