Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7424 closed enhancement (worksforme)

don't mail if event.author == ticket['owner']

Reported by: anonymous Owned by: doki_pen
Priority: normal Component: AnnouncerPlugin
Severity: normal Keywords: opt-out author
Cc: xilent, hasienda Trac Release: 0.12

Description

Maybe you can create a config option to disable mails if the ticket update / comment comes from the ticket owner himself.

dont_mail_if_updater_is_owner = true 

I'm getting 10 Mails a day about self commented tickets.

I've tried to hack it into your module, but my python knowledge is very basic ;-)

Attachments (0)

Change History (8)

comment:1 Changed 4 years ago by xilent

  • Cc xilent added

comment:2 Changed 4 years ago by rjollos

I believe this can be accomplished with the NeverNotifyUpdaterPlugin, but it may be worthwhile to integrate it directly.

We may have had to hack the NeverNotifyUpdaterPlugin slightly to make it compatible with the AnnouncerPlugin (0.11 branch).

comment:3 Changed 4 years ago by hasienda

  • Cc hasienda added
  • Keywords opt-out author added

I'm not convinced, that we need another option. Why doesn't the author filter "Never notify me when I make a change." work for you?

comment:4 follow-up: Changed 4 years ago by rjollos

I think that, as hasienda pointed out, this feature is already implemented and my comment:2 was incorrect. However, you may need to navigate to the preferences panel and click save. Its possible there is an issue similar to what I reported in #6631.

comment:5 in reply to: ↑ 4 Changed 4 years ago by hasienda

Replying to rjollos:

![...] Its possible there is an issue similar to what I reported in #6631.

That is a quite elaborated bug report, that I haven't noticed before. Thanks for pointing at it. I may come back to you for comments or even testing, as soon as I've done more on AnnouncerPlugin.

Still I hope to get feedback from the reporter, since otherwise this ticket might easily get closed with "worksforme" solution attached.

comment:6 Changed 4 years ago by xilent

  • Resolution set to worksforme
  • Status changed from new to closed

hi, updated from 0.11dev to trunk and found the option "Never notify me when I make a change."

thats what i've searched for.

Thx

comment:7 Changed 4 years ago by hasienda

Oh, very well. Glad you've got it working, and thanks for telling us.

comment:8 Changed 4 years ago by rjollos

#7512 appears to be a duplicate of this ticket.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from doki_pen. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.