Modify

Opened 4 years ago

Closed 4 years ago

#7679 closed defect (fixed)

Status & Project name ignored

Reported by: mintsauce Owned by: anonymous
Priority: high Component: TicketImportPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

I'm trying to import tickets from an old (Roundup) database via TicketImport 0.8 to a fresh, empty Trac 0.11.

I have an exported, cleaned CSV file with either column titles matching the Trac defaults, or custom titles created with TracCustomFieldAdmin 0.2.3.

It seems to work fine, apart from:

  • Status - Whether I change the value to match the trac defaults, or create my own, this is field is ignored every time and defaults to 'new'. Other trac fields like 'Type' import fine. Even more frustratingly the preview shows the fields and values importing as expected.
  • My custom field 'Project' does not import. Other custom fields are fine. Perhaps it's a reserved name?

While annoying, I can live with the last one, but the first is becoming a blocker to Trac's acceptance as a replacement to roundup.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by mintsauce

  • Priority changed from normal to high
  • Severity changed from normal to major

I have just tested this on a completely fresh Ubuntu installation and encountered exactly the same problem.

I tried in both trac 0.11 and 0.12

comment:2 Changed 4 years ago by anonymous

  • Owner changed from farialima to anonymous
  • Status changed from new to assigned

comment:3 Changed 4 years ago by anonymous

  • Resolution set to fixed
  • Status changed from assigned to closed

Committed a fix for the first part ('status' field does not import) in [9723], and a test for the second part ('project' custom field does not import) in [9724], but unable to reproduce this second part. Can you try again, and/or give more details ?

Add Comment

Modify Ticket

Action
as closed The owner will remain anonymous.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.