Modify

Opened 4 years ago

Closed 4 years ago

#7743 closed defect (duplicate)

Error "No handler matched request to /mdashboard/<milestone>" on milestone links

Reported by: jnelson@… Owned by: rjollos
Priority: normal Component: TracMetrixPlugin
Severity: major Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

After installing the TracMetrix plugin and getting it working (verified by presence of "Metrics" tab, which does show a few charts and tables about my project's status), the milestone-specific pages return this error:

No handler matched request to /mdashboard/<milestone name>

In the error, <milestone name> is the name of the selected milestone. These are simple names, such as "M8" without the quotes.

PLEASE NOTE: This Trac installation has a thoroughly customized workflow in trac.ini. I notice from some of the query links that this plugin expects a more traditional configuration, since it is checking for status such as "accepted" or "assigned", neither of which exist in our workflow. We also have customized resolutions.

System Information:
User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.63 Safari/534.3

 Trac	0.12
 Genshi	0.6
 pysqlite	2.4.0
 Python	2.5.2 (r252:60911, Jan 20 2010, 21:48:48) [GCC 4.2.4 (Ubuntu 4.2.4-1ubuntu3)]
 pytz	2007k
 RPC	1.0.6
 setuptools	0.6c8
 SQLite	3.4.2
 Subversion	1.4.6 (r28521)
 jQuery	1.4.2

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by rjollos

  • Description modified (diff)
  • Status changed from new to assigned

Please do the following:

  • Post your customized workflow and resolution (from trac.ini).
  • Set the log level to Debug and post any stack trace.

Thanks!

comment:2 Changed 4 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from assigned to closed

I'm going to close this as a duplicate of #6525 since it appears to be an issue with a custom workflow. Feel free to reopen or follow-up in #6525 if you have more information.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.