Modify

Opened 8 years ago

Closed 4 years ago

Last modified 16 months ago

#809 closed enhancement (fixed)

Fit long user list display in account admin page to one screen height adding vertical scrollbar

Reported by: mjs@… Owned by: hasienda
Priority: low Component: AccountManagerPlugin
Severity: trivial Keywords: admin web_ui account
Cc: Trac Release: 0.11

Description

On the WebAdmin page for managing accounts, if an account has the name field and e-mail field filled in, the display table is wide enough to overlap the Add Account box, which is apparently a fixed distance from the right edge of the browser window. It looks OK if the browser is in full-screen mode, but not if it is narrower than the screen.

Attachments (2)

screenshot-top.png (167.2 KB) - added by mjs@… 4 years ago.
Screenshot of top of account admin page.
screenshot-bottom.png (106.8 KB) - added by mjs@… 4 years ago.
Screenshot of bottom of account admin page.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by anonymous

  • Priority changed from normal to low
  • Severity changed from normal to trivial

comment:2 Changed 4 years ago by hasienda

  • Keywords needinfo admin web_ui added
  • Owner changed from mgood to hasienda

Sorry for the long time without any reaction.

I'm unable to reproduce this with trunk version and Trac 0.12 right now. The accounts table does not overlap but scrolls. In fact looks even better to me than the Trac web admin page for permission settings, that has a similar design in full-screen size.

I may try to fix it for 0.11, not 0.9 anymore, if there would be an issue related to that Trac version, so verify and report back, please.

comment:3 Changed 4 years ago by mjs@…

We've moved on to 0.12, so 0.9 and 0.11 aren't a concern for us anymore.

The horizontal scrolling works, but you have to scroll down to the very end of the page to invoke it. If you have many accounts (we have over 700), that's kind of painful. It would be nice if there were a cutoff, beyond which the names appeared in a window with both horizontal and vertical scroll bars that fit in a single view of the browser window. (I guess in the permissions window, the browser scroll bar is enough, as there is apparently no horizontal scrolling.)

Thanks for your help.

comment:4 Changed 4 years ago by hasienda

  • Keywords account added; needinfo removed
  • Summary changed from Display too wide on account admin page to Fit long user list display in account admin page to one screen height adding vertical scrollbar
  • Trac Release changed from 0.9 to 0.11
  • Type changed from defect to enhancement

I see, but I couldn't figure this out from original request.

In fact, this is a totally different thing, and it's mainly to better reach the "Remove selected accounts" button, since this is the only thing, that is pushed down by a big table, right? Anyway limiting list length sounds like a reasonable request considering your use case. Only I've not thought about it, since I did never encounter more than a dozen users per project by now.

Since it would be a pain for me to create dozens of dummy users just to see what you see, would you share a screen capture with the relevant view (obfuscating any private content of course), please?

Changed 4 years ago by mjs@…

Screenshot of top of account admin page.

Changed 4 years ago by mjs@…

Screenshot of bottom of account admin page.

comment:5 Changed 4 years ago by mjs@…

I'm attaching shots of the top of a browser window (see the way the Last Login field is obscured) and the bottom (see the scrollbar and the Remove button. The height of the slider in the browser's scroll bar on the right gives some indication of how far down I had to scroll to move the slider to the right to see that the obscured field was indeed Last Login.

comment:6 follow-up: Changed 4 years ago by hasienda

  • Status changed from new to assigned

Thank you, exactly what I wanted to see confirmed.

I'll try to take care of this after resolving some security related issues. Actually there's so much to be done here to catch up with maintenance after the plugin was practically unmaintained for half a year. Please nudge me again, if it looks like I've forgotten about this before end of the year.

comment:7 in reply to: ↑ 6 Changed 4 years ago by mjs@…

Replying to hasienda:

Thank you, exactly what I wanted to see confirmed.

I'll try to take care of this after resolving some security related issues. Actually there's so much to be done here to catch up with maintenance after the plugin was practically unmaintained for half a year. Please nudge me again, if it looks like I've forgotten about this before end of the year.

OK Thx.

comment:8 Changed 4 years ago by hasienda

Rather simple fix tested with FF3 (FireBug activ) and Opera9. I'll push this out now, looking forward to receiving your feedback too. Enjoy.

comment:9 Changed 4 years ago by hasienda

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [9583]) AccountManagerPlugin: Limit user list at users admin page, closes #809.

So we get vertical scrollbar aside the user list table and keep the
"Remove selected accounts" button below visible regardless of list
length. Improve navigation for new account details admin page
by changing previously silent redirect into redirect with warning message
explaining the reason why.

comment:10 Changed 16 months ago by hasienda

(In [12738]) AccountManagerPlugin: Move pager to user list in accounts admin panel, refs #809, #9946, #10682, #10745, #10754 and #10873.

This should fix broken display of extra-long user lists, and it makes
selections from user list useful for the clean-up page as requested.

Dumped access to anonymous session attributes for the current solution,
so these are no longer available for clean-up in the admin web-UI, but
I'll re-implement this later on, if it will be missed too much.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.