Modify

Opened 8 years ago

Closed 18 months ago

#840 closed defect (wontfix)

pressing delete link in ticket comments ticks the wrong comment

Reported by: moo Owned by: rjollos
Priority: high Component: TicketDeletePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

when there's a ticket comment deleted in the middle, say. 1 2 3 4, and 2 is deleted already (i guess)
if i press "delete" on 3, it ticks the wrong comment in the admin page.

ticking the "change at *" also won't ticks the fields

Attachments (0)

Change History (20)

comment:1 Changed 4 years ago by rjollos

  • Owner changed from coderanger to rjollos
  • Status changed from new to assigned

I think this may be related to #6535. I'll take a look.

comment:2 Changed 4 years ago by rjollos

  • Priority changed from normal to high

comment:3 Changed 3 years ago by rjollos

  • Status changed from assigned to new

comment:4 follow-up: Changed 2 years ago by rjollos

  • Resolution set to wontfix
  • Status changed from new to closed

0.10 is no longer supported.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 2 years ago by ChrisNelson

Replying to rjollos:

0.10 is no longer supported.

OK. But I still see this in 0.11.6 (using plugin version 2.0). Was there a similar ticket against 0.11? Is this fixed in 3.0?

comment:6 in reply to: ↑ 5 ; follow-up: Changed 2 years ago by rjollos

Replying to ChrisNelson:

OK. But I still see this in 0.11.6 (using plugin version 2.0). Was there a similar ticket against 0.11? Is this fixed in 3.0?

I had thought the issue was fixed in [6924]. I haven't been able to reproduce. There were several revs of version 2.0, which is why I started tagging the egg builds with the SVN revision. Do you know what SVN revision you are currently running?

If you can test with 3.0dev and reproduce the issue, I'll get it fixed.

comment:7 in reply to: ↑ 6 Changed 2 years ago by ChrisNelson

Replying to rjollos:

Replying to ChrisNelson:

OK. But I still see this in 0.11.6 (using plugin version 2.0). Was there a similar ticket against 0.11? Is this fixed in 3.0?

I had thought the issue was fixed in [6924].

That diff doesn't seem to relate to this issue. The problem is that Trac doesn't number at least attachments and maybe edits of the description and the deletion is invoked with "&cnum=n" but instead of looking for 'n' in the oldvalue field where comments are numbered, it looks for the nth group of ticket changes so unnumbered changes (like attachments) throw the delete plugin off.

I haven't been able to reproduce.

  • Create a ticket
  • Add a comment
  • Edit the description
  • Attach a file
  • Add a comment
  • Respond to one of the comments
  • Delete one of the comments

So far, so good.

  • Try to delete on of the other comments

The wrong one is checked on the delete preview. (It may matter which one you comment on and which one you delete first. I'll verify when I test this.)

There were several revs of version 2.0, which is why I started tagging the egg builds with the SVN revision. Do you know what SVN revision you are currently running?

No, sorry.

If you can test with 3.0dev and reproduce the issue, I'll get it fixed.

I'll try to do this today or tomorrow.

comment:8 Changed 2 years ago by rjollos

  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Trac Release changed from 0.10 to 0.11

comment:9 Changed 2 years ago by rjollos

  • Status changed from reopened to new

comment:11 follow-ups: Changed 2 years ago by ChrisNelson

Downloaded the .zip from the plugin page and installed. It says it's "3.0.0dev". For me, this behaves worse than 2.0. I don't like the reverse chronological sort of changes. But apropos of this ticket, the wrong change is checked. Let me know if the sequence above isn't enough to reproduce it.

comment:12 in reply to: ↑ 11 Changed 2 years ago by rjollos

Replying to ChrisNelson:

Downloaded the .zip from the plugin page and installed. It says it's "3.0.0dev". For me, this behaves worse than 2.0. I don't like the reverse chronological sort of changes.

There were so pretty major changes in [11802], which dropped all of the JavaScript and implemented everything in Python via Genshi. This should have resolved several possible plugin conflicts, see comment:35:ticket:1749. However, I'm not surprised that there might be some behavior changes that I didn't notice when modifying and applying the patch.

I'm happy to fix any specific behavior change you don't like if you open a ticket for the issue.

But apropos of this ticket, the wrong change is checked. Let me know if the sequence above isn't enough to reproduce it.

I'll focus on fixing this issue first.

comment:13 Changed 2 years ago by rjollos

  • Keywords regression added

comment:14 in reply to: ↑ 11 ; follow-up: Changed 2 years ago by rjollos

Replying to ChrisNelson:

It says it's "3.0.0dev". For me, this behaves worse than 2.0. I don't like the reverse chronological sort of changes.

Do you want the most recent change at the bottom of the page, or at the top of the page?

comment:15 in reply to: ↑ 14 ; follow-up: Changed 2 years ago by ChrisNelson

Replying to rjollos:

Replying to ChrisNelson:

It says it's "3.0.0dev". For me, this behaves worse than 2.0. I don't like the reverse chronological sort of changes.

Do you want the most recent change at the bottom of the page, or at the top of the page?

I want the most recent change at the bottom, same order as in the ticket. (Unless Trac 1.0 implemented a last at the top ordering or something, then it gets ugly.)

comment:16 in reply to: ↑ 15 Changed 2 years ago by rjollos

Replying to ChrisNelson:

I want the most recent change at the bottom, same order as in the ticket. (Unless Trac 1.0 implemented a last at the top ordering or something, then it gets ugly.)

In Trac 1.0 you can reverse the sorting with a radiobutton selection, but this plugin is not needed with Trac 0.12 and later, so it won't be an issue for us.

comment:17 Changed 2 years ago by rjollos

(In [12098]) Refs #840, #10263:

  • Added check of Trac version. The plugin won't install in Trac 0.12 and later. In Trac 0.12 and later, enable the equivalent functionality by setting tracopt.ticket.deleter = enabled.
  • When a "change" checkbox is selected, all of the child "field" checkboxes will be selected.
  • Improved warning that is issued when an invalid ticket ID is entered. The left # characters in case the user enters #100 for a ticket ID, rather than 100.
  • Fixed some regressions introduced in #840, when migrating from the javascript version of the plugin, to the genshi version.
    • Alert confirmation dialog has been restored.
    • Changes sort chronlogically.


Please test and report back, if you can.

comment:18 Changed 2 years ago by rjollos

Note that I haven't yet addressed the issue in comment:7.

comment:19 Changed 2 years ago by rjollos

(In [12099]) Refs #840, #10263: FIX: the reply buttons were redirecting to the delete page as well.

comment:20 Changed 23 months ago by rjollos

  • Keywords regression removed

Most likely, nothing will happen with this ticket unless someone provides a patch. Following #10263, we have a version of TicketDeletePlugin that utilizes ITemplateStreamFilter to modify the Genshi template. Since Trac 0.12 supports ticket deletion, I have little motivation to do additional work on this plugin. I'd welcome a patch though!

comment:21 Changed 18 months ago by rjollos

  • Resolution set to wontfix
  • Status changed from new to closed

Closing tickets for deprecated plugin.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.