Modify

Opened 4 years ago

Closed 4 years ago

#8490 closed defect (duplicate)

AttributeError: 'TracError' object has no attribute 'acctmgr'

Reported by: admin Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: Trac error
Cc: Trac Release: 0.11

Description

How to Reproduce

While doing a POST operation on /admin/accounts/users, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'4df5d81d6d357e3aa27a87c0',
 'add': u' Add ',
 'cat_id': u'accounts',
 'email': u'PSimons@RoutIT.nl',
 'name': u'Patrick Simons',
 'panel_id': u'users',
 'password': u'LS180309',
 'password_confirm': u'LS180309',
 'path_info': None,
 'user': u'Patrick'}

User agent: Opera/9.80 (Windows NT 6.1; U; Edition Campaign 21; en) Presto/2.7.62 Version/11.01

System Information

Trac 0.12.2
Agilo 1.3.3-pro
Genshi 0.6
pysqlite 2.3.2
Python 2.5.4 (r254:67916, Dec 23 2008, 15:10:54) [MSC v.1310 32 bit (Intel)]
setuptools 0.6c9
SQLite 3.3.4
Subversion 1.5.6 (r36142)
jQuery 1.4.2

Enabled Plugins

binary-agilo 1.3.3-pro
tracaccountmanager 0.2.1dev-r5836

Python Traceback

Traceback (most recent call last):
  File "c:\docume~1\admini~1\locals~1\temp\easy_install-8irbu9\Trac-0.12.2-py2.5-win32.egg.tmp\trac\web\main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "c:\docume~1\admini~1\locals~1\temp\easy_install-8irbu9\Trac-0.12.2-py2.5-win32.egg.tmp\trac\web\main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "c:\docume~1\admini~1\locals~1\temp\easy_install-8irbu9\Trac-0.12.2-py2.5-win32.egg.tmp\trac\admin\web_ui.py", line 116, in process_request
    path_info)
  File "build\bdist.win32\egg\acct_mgr\admin.py", line 117, in render_admin_panel
    return self._do_users(req)
  File "build\bdist.win32\egg\acct_mgr\admin.py", line 188, in _do_users
    data['acctmgr'] = e.acctmgr
AttributeError: 'TracError' object has no attribute 'acctmgr'

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by rjollos

  • Component changed from SELECT A HACK to AccountManagerPlugin
  • Owner changed from anonymous to hasienda

comment:2 Changed 4 years ago by hasienda

  • Keywords Trac error added

Running such an old version of the AccountManagerPlugin with current Trac is certainly no a good idea. Would you mind to update and re-check this, please? I think we fixed the "no attribute 'acctmgr'" issue in trunk some time ago.

Next, knowing more about what you did before this error would be more helpful than just the uncommented Tracback information alone. And who is admin? We'll run into serious communication problems, if you're not keeping in touch, i.e. by getting comments by email, so you get noticed on requests, further comments and changes automatically.

comment:3 Changed 4 years ago by hasienda

  • Resolution set to duplicate
  • Status changed from new to closed

See #7063, #7147 and #7254. Looks like you're hitten by a quite old bug.

Sorry, I really need to get a new stable release out of the door.

Meanwhile you should really take a look at the trunk version and report back your findings, if there's something missing or a late regression (I doubt so, anyway YMMV).

Add Comment

Modify Ticket

Action
as closed The owner will remain hasienda.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.