Modify

Opened 3 years ago

Closed 3 years ago

#8697 closed defect (fixed)

Metanav is missing Register and Forgot your password Links with acct_mgr.web_ui.registrationmodule = enabled

Reported by: anonymous Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: web_ui login register
Cc: info@… Trac Release: 0.12

Description (last modified by rjollos)

Why is the register link not visible.

In the trac.ini, there is set

acct_mgr.web_ui.registrationmodule = enabled

I use ... ubuntu 10.04 LTS + Trac 0.12.2

Thank you ...

Attachments (1)

accountmanagerplugin-metanav-fix.patch (907 bytes) - added by oxullo@… 3 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 3 years ago by rjollos

  • Component changed from SELECT A HACK to AccountManagerPlugin
  • Description modified (diff)
  • Owner set to hasienda

Please set your log level to debug with output to the console and report back if you find any plugin loading errors.

comment:2 Changed 3 years ago by oxullo@…

Same here, Debian 5.0.8, trac 0.12.2, AccountManager plugin trunk r10079. Exactly the same thing under OSX, tracd-session, same versions as above and a pristine installation:

[components]
acct_mgr.admin.accountguardadminpage = enabled
acct_mgr.admin.accountmanageradminpage = enabled
acct_mgr.api.accountmanager = enabled
acct_mgr.db.sessionstore = enabled
acct_mgr.htfile.abstractpasswordfilestore = enabled
acct_mgr.htfile.htdigeststore = disabled
acct_mgr.htfile.htpasswdstore = enabled
acct_mgr.http.httpauthstore = disabled
acct_mgr.notification.accountchangelistener = enabled
acct_mgr.notification.accountchangenotificationadminpanel = enabled
acct_mgr.pwhash.htdigesthashmethod = disabled
acct_mgr.pwhash.htpasswdhashmethod = enabled
acct_mgr.svnserve.svnservepasswordstore = disabled
acct_mgr.web_ui.accountmodule = enabled
acct_mgr.web_ui.emailverificationmodule = enabled
acct_mgr.web_ui.loginmodule = enabled
acct_mgr.web_ui.registrationmodule = enabled
trac.web.auth.loginmodule = disabled

Debug information yield no errors nor warnings on both envs. The registration link appears under the login form, but not on the metanav.

As soon as:

trac.web.auth.loginmodule = disabled

is commented out, Register and Forgot your password? appear again.

comment:3 in reply to: ↑ description Changed 3 years ago by hasienda

  • Keywords web_ui login register added
  • Resolution set to duplicate
  • Status changed from new to closed

Replying to anonymous:

Why is the register link not visible.

Not true, it is, only not in the common place but has been moved conditionally into a new-style login box, if login module is enabled, see #6821 for discussion and development notes, [9577] and [9584] for related changes.

Sorry for any inconvenience. But I made some effort to make it public, at least with clear commit messages, so getting familiar with that embedded documentation while using trunk (=development) code would prevent confusion and save you a lot of time.

Would you like to have the link back? Would you agree to have it in both places, old and new one, configurable? I confess this has been somewhat hidden by late changes of summary for #6821. Discuss there, suggestions welcome. Thanks for testing and taking your time to report back.

comment:4 follow-up: Changed 3 years ago by oxullo@…

  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Summary changed from No Register Link visible by acct_mgr.web_ui.registrationmodule = enabled to Metanav is missing Register and Forgot your password Links with acct_mgr.web_ui.registrationmodule = enabled

Dear hasienda, I think that we were both talking about the missing links on the metanav, not the login form. Please give a look at the attached patch.

Changed 3 years ago by oxullo@…

comment:5 in reply to: ↑ 4 Changed 3 years ago by hasienda

Replying to oxullo@gmail.com:

Dear hasienda, I think that we were both talking about the missing links on the metanav, not the login form.

Yes, I think I know. Only I tried to explain, that this is connected by the code in question.

Please give a look at the attached patch.

Did it. You try to revert something that was introduced in aforementioned changesets. But did YOU take a look at that references in comment 3? I don't see you've got, that there has been these changes to the development branch resulting in removal of requested metanav links by intention.

I do invite you to move over to what I think is the right place (#6821), where discussion of these changes should happen. By now I only guess you think that this is a regression and should be reverted. Right? But what's so wrong with having the links in the login box? I'd really like to involve you into a design discussion, since at the time when I tried before making the changes no one did take care, and I'm glad this is brought up at least now.

comment:6 Changed 3 years ago by oxullo@…

  • Resolution set to fixed
  • Status changed from reopened to closed

Dear hasienda, my apologies, I lazily jumped to conclusions as soon as I looked at the changeset. I don't want to make you waste more time on it. I'll keep going on #6821

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.