Modify

Opened 3 years ago

Closed 18 months ago

#8818 closed defect (fixed)

CSS definitions not read

Reported by: panos@… Owned by: hasienda
Priority: normal Component: WikiTicketCalendarMacro
Severity: normal Keywords: CSS
Cc: rjollos Trac Release: 0.11

Description (last modified by rjollos)

I have installed WikiTicketCalendar and I am happy with what it shows however it does not seem to read its own css and as a result it appears so flat that it makes it difficult to read. Its just a bunch of text in the background with no line separating the tiles of the table etc.

I have changed, through the Admin->Theme->Customize, the colors of the default theme as follows:

/* Warning: this file is auto-generated. If you edit it, changes will be lost the next time you use the simple customizer. */
body, .milestone .info h2 *:link, .milestone .info h2 *:visited {
  color: #000000;
}

body {
  background-color: #C7CDD1;
}

*:link, *:visited, #tabs *:link, #tabs *:visited, .milestone .info h2 em {
  color: #003366;
}

*:link:hover, *:visited:hover, #tabs *:link:hover, #tabs *:visited:hover {
  color: #555555;
}

#mainnav {
  background-color: #FFFFFF;
}

#mainnav .active *:link, #mainnav .active *:visited {
  background-color: #000000;
}

#mainnav *:link:hover, #mainnav *:visited:hover {
  background-color: #CCCCCC;
}

I am attaching a jpg so that you can see how the WTC appears on the Wiki Page.

Please help!

Attachments (1)

wtc.jpg (98.9 KB) - added by panos@… 3 years ago.
Wiki Ticket Calendar - Broken View

Download all attachments as: .zip

Change History (12)

Changed 3 years ago by panos@…

Wiki Ticket Calendar - Broken View

comment:1 follow-up: Changed 3 years ago by hasienda

  • Keywords needinfo CSS added
  • Summary changed from CSS not read to CSS definitions not read

Would you be so kind as to refer to the exact version, or even better: try the latest code from WikiCalenderPlugin trunk. I've merged sources back to the origin and will support both macros in a single package. Since I use it myself in production and it worksforme, you really need to tell me more about your environment (how to reproduce). Thanks for taking care.

comment:2 in reply to: ↑ 1 Changed 3 years ago by hasienda

Replying to hasienda:

Would you be so kind as to refer to the exact version, or even better: try the latest code from WikiCalenderPlugin trunk.

sorry, correct: WikiCalendarMacro

comment:3 Changed 3 years ago by panos@…

Hello. I installed this "wikiticketcalendarmacro-r10217.zip" on Trac package "Trac-0.12.2-py2.6.egg". I am using the default theme but have changed the colors a little.
What do you mean by trunk? I dont think I have installed such a version of wtc. How do I do this?

Thank you for you support!

comment:4 Changed 3 years ago by hasienda

Please re-read correctly: WikiCalendarMacro is the predecessor to WikiTicketCalendarMacro. Both lacked maintenance for quite some time resulting in a variety of patched versions without moderation and versioning.

I started to cleanup the version mess for WikiTicketCalendarMacro last year. Afterwards rjollos and I decided that it would be a win-win situation for users and future development, if I merged both, so pending issues for WikiCalendarMacro could be resolved same way as done for the sister plugin, you see? I speak of WikiCalendarMacro as the place, where the functionality of both former independent code trees will be developed from now on. Install one, get two macros.

Beware, there are single-file and packaged versions. Full capabilities are only available with the packaged (Python egg) version.

trunk is the name commonly used in software development for the active development repository tree. So this is you link, if you care to help improve the latest version. http://trac-hacks.org/changeset/latest/wikicalendarmacro?old_path=/&filename=wikicalendarmacro&format=zip

Hope, this makes the situation clearer for you now. Please don't hesitate to ask more questions, if not.

comment:5 Changed 3 years ago by panos@…

Hello. As per your recommendation I removed wikiticketcalendarmacro-r10217.zip and have installed the trunk version included within wikicalendarmacro-r10223.zip. I still get the same visual result... Any ideas?

comment:6 Changed 3 years ago by hasienda

At first glance it looks like working in a theme admin menu (as mentioned above) would be a common procedure.

Happens I've never done so, even don't know, what plugin provides such a functionality. At least it's not a native Trac's functionality and you really need to present more details on your customization approach. What you should take for granted is, that the plugin regardless of branch (single-file vs. packaged - Python egg version) generally works and produces visual results similar to what is reproduced in the wiki page. CSS is even embedded into the single-file version (0.11 branch), so it can hardly be missed. Try this, if you missed it by now.

Anyway I suspect, it's about how you changed the CSS styles that interferes with the common procedure done by add_stylesheet() from trac.web.chrome. Even if it really looks like a local installation/configuration issue I'll try to help as much as I can, but entirely depending on best possible insight into your setup.

comment:7 Changed 2 years ago by hasienda

  • Cc rjollos added
  • Keywords needinfo removed
  • Trac Release changed from 0.12 to 0.11

I was able to reproduce this with Trac 0.11 now.

Seems like an issue with late style-sheet file addition, that is done by jQuery.loadStyleSheet (see t:#8005 for a similar issue). While embedding the CSS into the page might help, this would clutter up the rendered HTML significantly, not to mention unneeded duplication on multiple macro calls per page. I hope there'll be another solution.

comment:8 Changed 2 years ago by rjollos

  • Description modified (diff)

comment:9 Changed 2 years ago by hasienda

(In [11746]) WikiCalendarMarco: Optionally embed CSS styles instead of using add_stylesheet, refs #8818.

This introduces a new option internal_css for the equally new upstream
configuration section wikicalendar. False is the default and that's fine,
unless you really need to force reading CSS style definitions.

I tried with ITemplateStreamFilter, but had to learn, that wiki macros are
expanded only afterwards, so including style definitions into the HTML page
seems like the only alternative to trac.web.chrome.add_stylesheet() so far.

comment:10 Changed 2 years ago by hasienda

Please try latest trunk version of WikiCalendarMacro with

[wikicalendar]
internal_css = True

added to your trac.ini.

I verified, that [11746] fixes missing CSS for both, WikiCalendarMacro and WikiTicketCalendarMacro in Trac 0.11. As always, feedback is highly appreciated to encourage pushing this to next stable release.

comment:11 Changed 18 months ago by hasienda

  • Resolution set to fixed
  • Status changed from new to closed

(In [12842]) WikiCalendarMacro: Releasing current, tested macro package as final product, closes #64, #578, #6636, #7564, #7653, #8818, #9568, #9718 and #9719.

After a long time one of the oldest Trac hacks (see changeset [53]) is united
with its ambitious fork WikiTicketCalendarMacro for convenience.
While maintaining separate wiki pages for both macros, upstream development
continues together in the source:wikicalendarmacro/trunk branch.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.