Modify

Opened 4 years ago

Closed 3 years ago

#8820 closed defect (duplicate)

Search fails with: AttributeError: 'NoneType' object has no attribute 'get_node'

Reported by: malkolm@… Owned by: rjollos
Priority: normal Component: RepoSearchPlugin
Severity: normal Keywords:
Cc: ejucovy Trac Release: 0.12

Description (last modified by rjollos)

Python Traceback Most recent call last:

File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 511, in _dispatch_request
  dispatcher.dispatch(req)
File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 237, in dispatch
  resp = chosen_handler.process_request(req)
File "build/bdist.linux-x86_64/egg/trac/search/web_ui.py", line 96, in process_request
  results = self._do_search(req, terms, filters)
File "build/bdist.linux-x86_64/egg/trac/search/web_ui.py", line 201, in _do_search
  or [])
File "build/bdist.linux-x86_64/egg/tracreposearch/search.py", line 79, in get_search_results
  self.indexer = Indexer(self.env)
File "build/bdist.linux-x86_64/egg/tracreposearch/indexer.py", line 134, in __init__
  self.reindex()
File "build/bdist.linux-x86_64/egg/tracreposearch/indexer.py", line 97, in wrap
  return f(*args, **kw)
File "build/bdist.linux-x86_64/egg/tracreposearch/indexer.py", line 242, in reindex
  for node in TracRepoSearchPlugin(self.env).walk_repo(self.repo):
File "build/bdist.linux-x86_64/egg/tracreposearch/search.py", line 52, in walk_repo
  for node in do_walk('/'):
File "build/bdist.linux-x86_64/egg/tracreposearch/search.py", line 41, in do_walk
  node = repo.get_node(path)


System Information:

Trac 	0.12.1
Genshi 	0.6
mod_wsgi 	3.3 (WSGIProcessGroup WSGIApplicationGroup 127.0.0.1|)
pysqlite 	2.4.1
Python 	2.6 (r26:66714, Nov 3 2009, 17:33:18) [GCC 4.4.1 20090725 (Red Hat 4.4.1-2)]
setuptools 	0.6c11
SQLite 	3.6.20
Subversion 	1.6.6 (r40053)
jQuery	1.4.2
Enabled Plugins:
NavAdd 	0.1 	/data/trac/projects/solar-scm/plugins/NavAdd-0.1-py2.6.egg
tracreposearch 	0.2 	/data/trac/projects/solar-scm/plugins/tracreposearch-0.2-py2.6.egg
TracTocMacro 	11.0.0.3 	/data/trac/projects/solar-scm/plugins/TracTocMacro-11.0.0.3-py2.6.egg

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by rjollos

Hello,

I took over maintainership of this plugin from athomas some time ago. There is a significant amount of work to do on this plugin, and I don't foresee having the time to do it all.

helend has written the TracSuposePlugin, which seems like a much better solution. Rather than writing the repository search functionality from scratch, a Trac interface to an existing repository search tool has been created. Rather than throwing more effort at this plugin, I'd prefer to help helend with enhancements to the TracSuposePlugin, or spend my time on other Trac plugin projects altogether.

I'd like to get some feedback and hear if anyone knows of a compelling reason to continue this project rather than moving to the TracSuposePlugin. Is there functionality in this plugin that doesn't exist in the TracSuposePlugin? I'm open to hearing all opinions and suggestions.

I'll leave these tickets open for about a week, but in all likelihood will close all of them and deprecate the plugin.

Thanks for your time,

  • Ryan

comment:2 Changed 3 years ago by rjollos

  • Description modified (diff)

comment:3 Changed 3 years ago by rjollos

  • Cc ejucovy added; anonymous removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7046, and I'd suggest trying out the MultiRepoSearchPlugin.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.