Modify

Opened 3 years ago

Closed 5 months ago

Last modified 5 months ago

#8821 closed enhancement (duplicate)

FlexibleReporterNotifcationPlugin not working

Reported by: anonymous Owned by: rjollos
Priority: high Component: FlexibleReporterNotificationPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

Hi,

I have downloaded FlexibleReporterNotifcationPlugin plugin and made changes in trac.ini file as required but it is not working as expected.Do I need to do any other changes or this plugin need any changes? My requirement is restrict the notification email to reporter only opening and closing a ticket, please help me, i need this.

Attachments (2)

api.py (2.4 KB) - added by o.rossmueller@… 5 months ago.
api.py working with Trac 1.0.*
t8821.patch (3.6 KB) - added by rjollos 5 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 months ago by anonymous

I am having the same issue, I am attempting to walk through the python code but have been unable to find the fix.

Can someone please direct me to where I can learn about testing and debuggind Trac Python code?

Changed 5 months ago by o.rossmueller@…

api.py working with Trac 1.0.*

comment:2 Changed 5 months ago by o.rossmueller@…

I got the plugin working with Trac 1.0.*, see the api.py attached.

comment:3 Changed 5 months ago by rjollos

  • Owner changed from CStrac to rjollos
  • Status changed from new to accepted

Would you kindly attach that as a patch file (trac:TracDev/SubmittingPatches)?

Changed 5 months ago by rjollos

comment:4 Changed 5 months ago by rjollos

There are two major issues with the patch t8821.patch (a diff of api.py against r11964):

  • We should not call open_environment in the plugin. The Environment object is bound to self.
  • The patch is not compatible with Trac < 1.0.

comment:5 Changed 5 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from accepted to closed

Duplicate of #7554. A fix will be committed against that ticket.

comment:6 Changed 5 months ago by rjollos

In 13701:

Complete rework of plugin, using ideas from #11210 in the patch by chris-at. Fixes #7554, Refs #8821, #11210.

Note that only one instance of the reporter in to_recipients is removed. So for instance, if the reporter is also the owner and always_notify_owner is True, then the reporter will still receive a notification.

This has been lightly tested, so please report back if you find any issues.

comment:7 Changed 5 months ago by rjollos

I used some of the ideas in api.py:ticket:11210 to prepare the fix for #7554. Please test it out and report back if you can.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.