Modify

Opened 3 years ago

Closed 3 years ago

#9197 closed defect (duplicate)

it doesn't work with python 2.4.x

Reported by: anonymous Owned by: Blackhex
Priority: normal Component: DiscussionPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

DiscussionPlugin: 0.11 (r10655)
Trac: 0.12.2
Server: mod_python.x86_64 3.2.8-3.1, python.x86_64 2.4.3-44.el5
Database: mysql 5.0.77
OS: Linux (CentOS)

Hello together,

I want to try to install the discussion plugin 0.11 on trac 0.12.2.
But your plugin does not work with python 2.4.x.

Mandatory Dependencies for trac 0.12 is: Python, version >= 2.4 and < 3.0
See: http://trac.edgewall.org/wiki/TracInstall

Following source files cause errors:
tracdiscussion/api.py
tracdiscussion/wiki.py
tracdiscussion/templates/discussion-macros.html
tracdiscussion/templates/topic-list-classic.html
tracdiscussion/templates/---maybe some more---

"Conditional Expressions" (PEP: 308) are the problems in your plugin.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by Blackhex

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.