Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#9550 closed defect (duplicate)

Add the ability to fetch a bunch of tickets in one go

Reported by: david@… Owned by: osimons
Priority: normal Component: XmlRpcPlugin
Severity: normal Keywords:
Cc: olemis Trac Release: 0.11

Description

I guess either alter ticket.get() to accept a list of ids or alter ticket.query() to return all ticket details so that the tickets can be fetched in !one query rather than multiple ones.

Hopefully this would speed up the fetching of multiple tickets

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by osimons

  • Resolution set to duplicate
  • Status changed from new to closed

This is really a duplicate of #1650.

The current best practice is ticket.query() to get IDs, and then a system.multicall() with ticket.get() for each ID.

comment:2 Changed 2 years ago by david@…

That's good enough for my purposes - thanks!

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from osimons. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.