Modify

Opened 3 years ago

Closed 2 years ago

#9569 closed defect (fixed)

"TypeError: expected string or buffer"

Reported by: xaminmo Owned by: anbo
Priority: normal Component: ProjectPlanPlugin
Severity: normal Keywords:
Cc: xaminmo Trac Release: 0.11

Description

Creating a ticket fails with "TypeError: expected string or buffer".

Tried with blocked/blocking tickets null and filled.

Tried on 11.6 and 11.7, same results.

Disable projectplan fixes the error.

Versions right now:

Trac: 0.11.6
Python: 2.5.6 (r256:88840, Dec 1 2011, 23:44:35) [GCC 4.3.2]
setuptools: 0.6c12
SQLite: 3.5.9
pysqlite: 2.6.3
Genshi: 0.5.1
Pygments: 1.4
Subversion: 1.6.17 (r1128011)
jQuery: 1.2.6
ProjectPlan 0.88.4
Python Traceback
Most recent call last:

    File "/home/xaminmo/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/main.py", line 450, in _dispatch_request
    File "/home/xaminmo/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/main.py", line 176, in dispatch
    File "/home/xaminmo/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/main.py", line 296, in _pre_process_request
    File "build/bdist.linux-x86_64/egg/projectplan/ppticketviewtweak.py", line 136, in pre_process_request
    File "build/bdist.linux-x86_64/egg/projectplan/ppticketviewtweak.py", line 244, in change_blocked_tickets
    File "build/bdist.linux-x86_64/egg/projectplan/ppticketviewtweak.py", line 190, in splitStringToTicketList 
Local variables:
current_ticket_id 	-1
r 	<_sre.SRE_Pattern object at 0x171fe40>
self 	<projectplan.ppticketviewtweak.PPTicketViewTweak object at 0x1a7f890>
tickets 	None

Attachments (1)

pp88.4_fail.png (32.1 KB) - added by xaminmo 3 years ago.
screenshot of new ticket form

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by xaminmo

screenshot of new ticket form

comment:1 Changed 2 years ago by anbo

  • Resolution set to fixed
  • Status changed from new to closed

[11373] (version 0.91.2) should solve the problem. However, I could not reproduce the situation where this problem should appear. Do not hesitate to reopen the ticket if the error is still occurs.

Duplicate to: #8879

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from anbo. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.