Modify

Opened 3 years ago

Closed 2 years ago

#9619 closed defect (duplicate)

IOError: (22, "invalid mode ('r') or filename")

Reported by: adminuser Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: IOError
Cc: Trac Release: 0.12

Description

How to Reproduce

While doing a POST operation on /admin/accounts/users, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'40f4b07837dd75a5cbea6f6a',
 'add': u' Add ',
 'cat_id': u'accounts',
 'email': u'trac.test@gmail.com',
 'name': u'',
 'panel_id': u'users',
 'password': u'12345',
 'password_confirm': u'12345',
 'path_info': None,
 'username': u'testuser'}

User agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

System Information

Trac 0.12.2
Genshi 0.6
mod_wsgi 3.0 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
pysqlite 2.4.1
Python 2.6.4 (r264:75708, Oct 26 2009, 08:23:19) [MSC v.1500 32 bit (Intel)]
setuptools 0.6c11
SQLite 3.5.9
Subversion 1.6.6 (r40053)
jQuery 1.4.2

Enabled Plugins

tracaccountmanager 0.3.2

Python Traceback

Traceback (most recent call last):
  File "build\bdist.win32\egg\trac\web\main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win32\egg\trac\web\main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\trac\admin\web_ui.py", line 116, in process_request
    path_info)
  File "build\bdist.win32\egg\acct_mgr\admin.py", line 137, in render_admin_panel
    return self._do_users(req)
  File "build\bdist.win32\egg\acct_mgr\admin.py", line 240, in _do_users
    _create_user(req, env, check_permissions=False)
  File "build\bdist.win32\egg\acct_mgr\web_ui.py", line 148, in _create_user
    acctmgr.set_password(username, password)
  File "build\bdist.win32\egg\acct_mgr\api.py", line 292, in set_password
    if store.set_password(user, password, old_password):
  File "build\bdist.win32\egg\acct_mgr\htfile.py", line 56, in set_password
    self.userline(user, password))
  File "build\bdist.win32\egg\acct_mgr\htfile.py", line 106, in _update_file
    f = open(filename, 'r')
IOError: [Errno 22] invalid mode ('r') or filename: ''

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by rjollos

  • Component changed from SELECT A HACK to AccountManagerPlugin
  • Owner set to hasienda

Yet another incorrectly filed ticket.

comment:2 Changed 2 years ago by hasienda

  • Keywords IOError added
  • Resolution set to duplicate
  • Status changed from new to closed

See #9623, that is about to be closed too, because there is not enough information and no response from the reporter for a rather long time.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.