Modify

Opened 3 years ago

Closed 3 years ago

#9620 closed defect (duplicate)

Error upon calling /register on recaptchaplugin

Reported by: get@… Owned by: alecu
Priority: normal Component: RecaptchaRegisterPlugin
Severity: normal Keywords:
Cc: rjollos Trac Release: 0.12

Description

If anyone tries to register itself i get this error:

2011-12-16 09:10:47,082 Trac[main] ERROR: Internal Server Error: 
Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/recaptcharegister/web_ui.py", line 40, in process_request
    ret = super(RecaptchaRegistrationModule, self).process_request(req)
  File "build/bdist.linux-x86_64/egg/acct_mgr/web_ui.py", line 456, in process_request
    _create_user(req, self.env)
  File "build/bdist.linux-x86_64/egg/acct_mgr/web_ui.py", line 48, in _create_user
    req.args.get('username').strip())
AttributeError: 'NoneType' object has no attribute 'strip'

any ideas why?

Attachments (0)

Change History (1)

comment:1 in reply to: ↑ description Changed 3 years ago by hasienda

  • Cc rjollos added
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from error upon register on recaptchaplugin to Error upon calling /register on recaptchaplugin

Replying to get@winsucks.org:

If anyone tries to register itself i get this error:
...
any ideas why?

Yes, please search existing tickets for identical, similar and related issues first.

This is a duplicate of #9524.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from alecu. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.