Modify

Opened 10 years ago

Closed 10 years ago

Last modified 5 years ago

#10102 closed enhancement (duplicate)

Question concerning "base_dir" parameter

Reported by: David Owned by: Diorgenes Felipe Grzesiuk
Priority: normal Component: TracWikiToPdfPlugin
Severity: major Keywords: base_dir parameter
Cc: Trac Release: 0.11

Description (last modified by Ryan J Ollos)

Hy Diorgenes,

I really admire your pdf plugin but I can't get it working with images. My Trac environment is:

Trac: 0.11.7 
Python: 2.6.5
setuptools: 0.6 
SQLite: 3.6.22 
pysqlite: 2.4.1 
Genshi: 0.5.1 
mod_python: 3.3.1 
Pygments: 1.2.2 
Subversion: 1.6.6 (r40053) 

I installed your wiki2pdf plugin with:

~#apt-get install htmldoc
~#apt-get install python-clearsilver
~#python setup.py install

My Apache config is set Document Root /var/www while Trac htdocs are stored in /var/home/database/trac/mytrac/.

Now I set up my trac.ini:

[wikitopdf]
# base_dir is the Apache DocumentRoot, It is need to get PDF files with images.
base_dir = /var/home/database/trac/ospelt/wiki/htdocs
#titlefile = /path/to/cover
link = https://apoit01/trac/ospelt
folder_name = Trac Ospelt

[wikitopdf-admin]
size = A4
charset = iso-8859-1
right = 1.0cm
left = 1.5cm
top = 1.0cm
bottom = 1.0cm
no-links = None
toctitle = Summary
numbered = None
linkstyle = plain
header = ...
footer = .r1
logoimage = /var/home/database/trac/ospelt/wiki/htdocs/logo.jpg
permissions = None
landscape = 1
fontsize = 6

[wikitopdf-page]
size = A4
charset = iso-8859-1
right = 1.0cm
left = 1.5cm
top = 1.0cm
bottom = 1.0cm
no-links = None
linkstyle = plain
header = ...
footer = .r1
logoimage = /var/home/database/trac/ospelt/wiki/htdocs/logo.jpg
permissions = None
landscape = 1
fontsize = 6

Now base_dir should point to Apache Document Root. But I got no images in the generated pdf. I tried the following paths, without success: Absolute paths:

/var/www
/var/home/database/trac/mytrac
/var/home/database/trac/mytrac/wiki
/var/home/database/trac/mytrac/wiki/htdocs
/var/home/database/trac/mytrac/attachment/wiki

Apache alias Web paths:

/trac/mytrac/
/trac/mytrac/wiki
/trac/mytrac/

What should be set as base_dir? Also a complete installation guide would be fine.

Thanks for your help.

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #10103.

comment:2 Changed 5 years ago by Ryan J Ollos

Description: modified (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Diorgenes Felipe Grzesiuk.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.