Opened 4 years ago

Closed 15 months ago

#10130 closed defect (fixed)

Installed but not working on Bitnami Trac stack 0.12.3

Reported by: tanguyr@… Owned by: qwp0
Priority: normal Component: ProgressMeterMacro
Severity: normal Keywords: setuptools
Cc: Trac Release: 0.12


  • I am running an "all in one" version: Bitnami Trac stack. This includes python 2.6, trac 0.12.3, and apache - all running on windows.
  • I downloaded the macro plugin and built the egg using bdist_egg. This seems to work and yields egg file TracProgressMeterMacro-0.3-py2.6.egg
  • I install this via the web interface, under /trac/[project]/admin/general/plugin
    • it doesn't show up in the Manage Plugins list (probably because there's nothing to manage)
    • the egg does show up in the project's plugins directory
    • if I try to install it again, I get an error message saying it's already installed

However, when I try to use this macro in a wiki page, I get the output for an unknown macro:


If I change "ProgressMeter" to "TicketQuery" I get results.

I have tried adding a block

progressmeter.* = enabled

to my trac.ini and restarting apache, but it doesn't change anything

Attachments (0)

Change History (11)

comment:1 Changed 4 years ago by rjollos

First thing to do is to set the t:TracLogging level to debug, reload Trac and look for errors related to the plugin.

comment:2 Changed 4 years ago by anonymous

I see this line:

2012-07-04 11:12:15,743 Trac[loader] DEBUG: Skipping "TracProgressMeterMacro 0.3": ("DistributionNotFound: Python>=2.5" not found)

I am running the version of python that came with the bitnami trac stack:

C:\sdc_devenv\opt\trac\python>python.exe --version
Python 2.6.2

comment:3 Changed 4 years ago by rjollos

Specifying a Python package requirement in the install_requires field seems to be problematic, see #10064. I'm not sure what the problem is, but for other plugins, users have reported that removing that line has fixed the issue. So I think you should just try removing the Python constraint in and reinstalling.

Also, I haven't looked closely at this, but it appears that t:TicketQuery macro supports a progress meter now, which may provide the same or similar functionality as the ProgressMeterMacro. I think the functionality was added with Trac 0.12.

comment:4 follow-up: Changed 4 years ago by tanguyr@…

  • removing the python version dependency in and rebuilding the egg seems to have fixed the problem.
  • just for info, the format=progress argument for the t:TicketQuery macro doesn't seem to work in trac 0.12.3

comment:5 in reply to: ↑ 4 Changed 4 years ago by rjollos

  • Keywords setuptools added

Replying to

  • just for info, the format=progress argument for the t:TicketQuery macro doesn't seem to work in trac 0.12.3

Looking more closely, it appears the progress option was added for Trac 1.0. So we still need this macro for Trac 0.12.

Thanks for testing that out.

comment:6 Changed 4 years ago by rjollos

qwp0: I'm not sure why adding a Python version restriction to is so problematic, but another way to approach the issue of restricting the install to specific versions of Python is discussed in comment:4:ticket:9800 and demonstrated in the Trac core

comment:7 Changed 4 years ago by qwp0

According to comment:ticket:7017:8, the issue is dependent on the version of setuptools installed. I'd personally enforce a higher version of setuptools or remove the Python constraint altogether, rather than to be cluttering up, since the problem can be easily dealt with in one's actual configuration (e.g., by removing the install_requires directive if desirable).

comment:8 follow-up: Changed 4 years ago by rjollos

This issue came up again today on IRC:

(13:05:02) spookah: I installed two plugins using the .egg file from the
trac web interface.. neither one shows in the list of plugins?
(13:05:16) spookah: when i try to reinstall it says they are already
installed.. any ideas?
(13:12:37) rjollos: spookah: recommend you turn  on Trac logging and
check whether the plugins are loading and if there are any errors in the
(13:57:01) spookah: thanks rjollos
(14:08:44) spookah: DEBUG: Skipping "progressmeter.macro =
progressmeter.macro": ("DistributionNotFound: Python>=2.6" not found)
(14:09:20) spookah: "c:\Program Files\BitNami Trac
Stack\python\python.exe" --version  - Python 2.6.2
(14:11:28) spookah: any idea why the plugin doesnt see the python
(14:12:53) sam: is "c:\Program Files\BitNami Trac Stack\python" in
(14:18:34) spookah: yes i added it earlier.. does it require a reboot?
(14:19:54) rjollos: spookah: there is a ticket about this issue.
Specifying a Python requirement in install_requires causes problems, but
the author has chosen to leave it. One moment and I will locate the
(14:20:13) rjollos: spookah: which version of Trac are you running?
(14:20:33) rjollos: spookah: ProgressMeterMacro is nearly obsoleted by
additions to Trac in 1.0
(14:20:35) spookah: 0.12.3
(14:21:19) spookah: is there a replacement? I wanted to use it with
(14:21:39) rjollos: spookah: I guess it won't help you now then, but if
you ever upgrade you may want to look at TicketQueryMacro
(14:22:18) rjollos: spookah: did you build the egg yourself?
(14:22:35) spookah: yes
(14:23:10) rjollos: spookah: I'd suggest deleting the install_requires
line from http://trac-
(14:23:21) rjollos: spookah: and then rebuilding the egg
(14:24:53) spookah: should I leave the line starting with classifiers
(14:25:43) rjollos: spookah: yes
(14:25:48) spookah: woop, that worked!
(14:25:51) rjollos: spookah: here is the ticket - http://trac-
(14:26:13) spookah: compiled and installed!

comment:9 in reply to: ↑ 8 ; follow-up: Changed 4 years ago by spookah

Replying to rjollos:

This issue came up again today on IRC:


To be clear deleting the entire line caused an error compiling the egg. The solution was to change the line to:

install_requires = ['Trac >= 0.12'],

comment:10 in reply to: ↑ 9 Changed 4 years ago by rjollos

Replying to spookah:

To be clear deleting the entire line caused an error compiling the egg. The solution was to change the line to:

install_requires = ['Trac >= 0.12'],

I'm not sure why that would be. I suppose there could have been an indentation problem after that line was deleted. Anyway, either should typically be fine.

comment:11 Changed 15 months ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

as closed The owner will remain qwp0.
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.