Modify

Opened 5 years ago

Last modified 3 years ago

#10172 new task

Release version 0.4.2 and 0.5.0 of plugin

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Component: AutocompleteUsersPlugin
Severity: normal Keywords:
Cc: Jun Omae, falkb Trac Release: 0.12

Description

Here is the development plan that I originally posted to comment:7:ticket:7324:

  • #6427 + #6444 + #7324 + #8477 + #10155 (and possibly #4442) -> 0.4.2 (Trac 0.11+)
  • #8438 + #9599 (and possibly #7605) -> 0.5 (Trac 0.12+)
  • Make compatible with Trac 1.0 by using jQuery UI that ships with Trac, assuming that it has Autocomplete support bundled in. This would be similar to the work I'm doing for the DateFieldPlugin in #10107.

My intent is to get all of the new features in a Trac 0.11 compatible version, branch and create port to jQuery UI 1.8, which will only be compatible with Trac 0.12+ and then add support for Trac 1.0.

Please post any thoughts on the plan.

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by Ryan J Ollos

(In [12687]) Refs #10172: Formatted source code (should not result in any functional changes).

comment:2 Changed 3 years ago by Tetsuya Morimoto

How about supporting Trac 1.0. Can I use trunk-version in Trac 1.0?

Version 0, edited 3 years ago by Tetsuya Morimoto (next)

comment:3 in reply to:  2 Changed 3 years ago by falkb

Replying to t2y:

Can I use trunk-version in Trac 1.0?

yes, works well here

comment:4 Changed 3 years ago by Ryan J Ollos

Just watch out for the issue described in comment:2:ticket:9599.

Modify Ticket

Action
as new The owner will remain Ryan J Ollos.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.