Modify

Opened 4 years ago

Closed 14 months ago

#10348 closed defect (worksforme)

DynamicFieldsPlugin affects Collapse/Expand/Foldable Functionality in Trac 0.12

Reported by: prav Owned by: robguttman
Priority: normal Component: DynamicFieldsPlugin
Severity: normal Keywords: collapsible/foldable
Cc: falkb Trac Release: 0.12

Description (last modified by rjollos)

Activating the (dynfields.web_ui.*) option of the DynamicFieldsPlugin affects Expand/Collapse functionality that is default in Trac 0.12.

The Attachments, Change History and Modify Tickets of the ticket view are collapsible, this functionality was made default from 0.12 (t:#8295). This bug deactivates it.

Please let me know if any more information/screenshots are necessary.

My Trac version: - Trac 0.12.3 Babel 0.9.5 Genshi 0.6

Attachments (1)

callStack-beforeError.PNG (128.9 KB) - added by jeremy.j.dunn@… 14 months ago.
js call-stack immediately before the error in header_layout.get_field()

Download all attachments as: .zip

Change History (14)

comment:1 Changed 4 years ago by robguttman

To clarify, which version of dynfields are you using? If you're using 0.12 please switch to 0.11 and let me know if you still have the problem.

comment:2 Changed 4 years ago by prav

I was using 0.11 when I encountered this error. I used 0.11 based on the suggestion on the plugin page. So this bug exists on 0.11 currently.

To check if the 0.12 might work, I switched it and found that this bug doesn't exist on 0.12 but I have other issues (the fields are not dynamic and are not working the way they are supposed to).

comment:3 Changed 4 years ago by rjollos

  • Description modified (diff)

comment:4 Changed 4 years ago by rjollos

Is anything seen in the browser's javascript error console?

comment:5 Changed 4 years ago by prav

I get the following error message when I click on "New Ticket" or view a ticket description.

[07:16:01.192] Use of attributes' specified attribute is deprecated. It always returns true. @/chrome/common/js/jquery.js:51
[07:16:01.235] TypeError: a.attributes is undefined @/chrome/common/js/jquery.js:55

comment:6 Changed 4 years ago by rjollos

What other plugins do you have installed? This is most likely a conflict with another plugin. Please try disabling all of them and see if the error goes away. Then enable them one-by-one until you find which plugin results in the error.

comment:7 Changed 4 years ago by prav

Hi, Here are a list of my installed plugins: -

Installed Plugins

ComponentDependencyPlugin 	0.1 	/plugins/ComponentDependencyPlugin-0.1-py2.5.egg
ImageTrac 	0.4 	/ImageTrac-0.4-py2.5.egg
mail2trac 	1 	/mailtotracplugin/0.12/plugin
ScreenshotPaste 	0.1.1 	/plugins/ScreenshotPaste-0.1.1-py2.5.egg
TicketConditionalCreationStatusPlugin 	0.2 	/plugins/TicketConditionalCreationStatusPlugin-0.2-py2.5.egg
TicketSidebarProvider 	0.0 	/plugins/TicketSidebarProvider-0.0-py2.5.egg
TracDynamicFields 	1.2.3 	/plugins/TracDynamicFields-1.2.3-py2.5.egg
TracTicketChainedFields 	0.1 	/plugins/TracTicketChainedFields-0.1-py2.5.egg

I tried doing what you said and it's the same thing, when all plugins are disabled it works, I enable them one by one and I get the error only when dynfields is enabled.

The only other odd thing I noticed is that I am unable to disable my TicketSidebarProvider plugin, it asks for an upgrade when I disable it and the upgrade enables it back again. Could this be an issue? Please advise.

comment:8 Changed 4 years ago by falkb

  • Cc falkb added; anonymous removed

I also see the described bug behaviour

comment:9 Changed 14 months ago by jeremy.j.dunn@…

just installed Dynfields and got the same result

javascript console error in dynfields/layout.js line 156

TypeError: th.attr(...) is undefined
	return th.attr('id').slice(2);

comment:10 Changed 14 months ago by jeremy.j.dunn@…

p.s. comment:9 running TracDynamicFields 2.2.0dev

comment:11 Changed 14 months ago by anonymous

sorry for so many comments. see attached screenshot of js call stack immediately before the error.

in the two-column ticket-property layout, there's an odd number of properties to display. The empty cell has a th tag with class="missing" but no "id" property. this is the starting point.

then, get_field() fails to handle lack of the id property in the th

the cause of the presenting problem is : the unhandled error in header_layout.get_field() causes jQuery to NOT RUN the document.ready() handler in the main ticket, which sets up the foldable-fields and a number of other functions.

Changed 14 months ago by jeremy.j.dunn@…

js call-stack immediately before the error in header_layout.get_field()

comment:12 follow-up: Changed 14 months ago by jeremy.j.dunn@…

again, sorry for multiple comments on this ticket. I see that the issue has already been fixed in /trunk/; but as an experienced trac user I don't see how to install that version. I'm doing easy_install https://trac-hacks.org/svn/dynamicfieldsplugin and it gives me the version which appears to correspond to /0.12/.

Any suggestions how I can run the /trunk/ version ?

comment:13 in reply to: ↑ 12 Changed 14 months ago by rjollos

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to jeremy.j.dunn@…:

Any suggestions how I can run the /trunk/ version ?

Just append trunk to the URL:

easy_install https://trac-hacks.org/svn/dynamicfieldsplugin/trunk

Add Comment

Modify Ticket

Action
as closed The owner will remain robguttman.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.