Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#10369 closed defect (duplicate)

TypeError: 'NoneType' object has no attribute '__getitem__'

Reported by: beta1.se Owned by: Radek Bartoň
Priority: normal Component: DiscussionPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

How to Reproduce

While doing a POST operation on /admin/discussion/forum, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'636903323ee06b05c6a05204',
 'cat_id': u'discussion',
 'discussion_action': u'delete',
 'group': '-1',
 'panel_id': u'forum',
 'path_info': None,
 'remove': u'Remove selected items',
 'selection': [u'1', u'2']}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:14.0) Gecko/20100101 Firefox/14.0.1

System Information

Trac 0.12.3
Trac 0.12.3
Agilo 0.9.7
Babel 0.9.6
Docutils 0.8.1
Genshi 0.6
GIT 1.7.10.3
mod_wsgi 3.3 (WSGIProcessGroup traclocal WSGIApplicationGroup %{GLOBAL})
Pygments 1.4
pysqlite 2.6.0
Python 2.7.3 (default, Aug 1 2012, 05:25:23)
[GCC 4.6.3]
Python 2.7.3 (default, Aug 1 2012, 05:25:23)
[GCC 4.6.3]
RPC 1.1.2
setuptools 0.6
setuptools 0.6
SQLite 3.7.9
Subversion 1.7.5 (r1336830)
jQuery 1.4.4

Enabled Plugins

agilo 0.9.7
BreadCrumbsNav 0.3dev
ComponentDependencyPlugin 0.1
TicketImport 0.8.2
TicketSidebarProvider 0.0
timingandestimationplugin 1.2.7
TracAnnouncer 0.12.1dev
TracBurndown 1.9.2dev
Tracchildtickets 2.4.5
TracDiscussion 0.8
TracGit 0.12.0.5dev
TracHoursPlugin 0.5.2
TracIncludePagesMacro 0.1
TracMasterTickets 3.0.2
TracTocMacro 11.0.0.3
TracWikiToPdfPlugin 2.3.1
TracWysiwyg 0.12.0.4
TracXMLRPC 1.1.2
TracXPDev 1.0

Python Traceback

Traceback (most recent call last):
  File "/opt/trac/current/lib/python2.7/site-packages/Trac-0.12.3-py2.7.egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/opt/trac/current/lib/python2.7/site-packages/Trac-0.12.3-py2.7.egg/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "/opt/trac/current/lib/python2.7/site-packages/Trac-0.12.3-py2.7.egg/trac/admin/web_ui.py", line 117, in process_request
    path_info)
  File "/srv/trac-deploy/plugins/TracDiscussion-0.8-py2.7.egg/tracdiscussion/admin.py", line 49, in render_admin_panel
    template, data = api.process_discussion(context)
  File "/srv/trac-deploy/plugins/TracDiscussion-0.8-py2.7.egg/tracdiscussion/api.py", line 259, in process_discussion
    self._do_actions(context, actions)
  File "/srv/trac-deploy/plugins/TracDiscussion-0.8-py2.7.egg/tracdiscussion/api.py", line 873, in _do_actions
    listener.forum_deleted(context, context.forum)
  File "/srv/trac-deploy/plugins/TracDiscussion-0.8-py2.7.egg/tracdiscussion/tags.py", line 72, in forum_deleted
    forum['id']))
TypeError: 'NoneType' object has no attribute '__getitem__'

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #9220.

comment:2 Changed 4 years ago by Ryan J Ollos

Fixed in [12055].

Modify Ticket

Action
as closed The owner will remain Radek Bartoň.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.