Opened 12 years ago

Closed 8 years ago

#10413 closed defect (worksforme)

Not getting the child ticket list in the parent ticket

Reported by: anonymous Owned by: Mark Ryan
Priority: normal Component: ChildTicketsPlugin
Severity: normal Keywords:
Cc: westp@… Trac Release: 0.12


Using the configuration changes from the plugin page, I added the .egg file to the plugins directory, Trac 0.12.4.

I created a child ticket, and specified #1313 as the parent ticket in the Parent ID field.

When I go back to 1313 I get nothing. I also don't see any reference to the childtickets.css file in the html source. It's picking up the new Parent ID field, but that's about it. I don't see any other configuration information, and there's no README, or INSTALL file in the egg or in the downloaded .zip file. I'm not sure if I've installed it correctly, that it's enabled correctly, or configured correctly. Any help would be greatly appreciated.

Attachments (0)

Change History (11)

comment:1 Changed 12 years ago by westp@…

Cc: westp@… added; anonymous removed

comment:2 Changed 12 years ago by dgrosvenor@…

So I was having the exact same problem and until I figured it out. I know I followed the configuration guide exactly but after restarting trac, the following lines weren't there anymore:

childtickets.* = enabled
childtickets.childtickets.tracchildticketsmodule = enabled

After adding the above lines back to the trac.ini file, the "Child Tickets" showed up. I still don't have the buttons to create a child ticket but I'm probably missing another configuration line. Hopefully this helps!

Douglas Grosvenor

comment:3 Changed 12 years ago by dgrosvenor@…

Looks like you just need to enable/configure it in the /admin/childticketsplugin/types settings. Hopefully this helps!


comment:4 Changed 12 years ago by anonymous

I go to admin/general/plugin. I upload the .egg file and it installs it in the plugins directory. And there it sits, that .egg file, never expanded, nothing ever happens to it. Even after I restart apache httpd. Just sits there.

And I can not browse to admin/childticketsplugin/types. I get "Unknown administration panel"

So I'm guessing I'm having a more basic issue with plugin installs. setup tools is installed. The plugins directory is owned by apache and writable by apache. I don't see anything in the log file for trac (I enabled loggin).

trac.ini looks like this:

childtickets.* = enabled
childtickets.childtickets.tracchildticketsmodule = enabled

parent = text
parent.format = wiki
parent.label = Parent ID


# 'enhancements' : child tickets will typically be bug-fix tickets with
# the same milestone, component and keywords.
parent.enhancement.allow_child_tickets = true
parent.enhancement.restrict_child_type = bug-fix, task
parent.enhancement.table_headers = type, status, owner, summary
parent.enhancement.inherit = milestone, component, keywords

# 'bug-report' : child tickets will typically be bug-fix
parent.bug-report.allow_child_tickets = true
parent.bug-report.default_child_type = bug-fix
parent.bug-report.table_headers = type, priority, owner, summary, milestone
parent.bug-report.inherit = component, keywords

# 'issue' : child tickets will typically be task tickets with no default
# milestone.
parent.issue.allow_child_tickets = true
parent.issue.restrict_child_type = task
parent.issue.table_headers = type, status, owner, summary, milestone

# 'bug-fix' : child tickets are not allowed.
parent.bug-fix.allow_child_tickets = false

# 'task' : child tickets are not allowed.
parent.task.allow_child_tickets = false

comment:5 Changed 12 years ago by anonymous

Also of note ... when I restart apache I get the following in the error log:

/usr/lib64/python2.4/site-packages/trac/ UserWarning: Module trac was already imported from /usr/lib64/python2.4/site-packages/trac/__init__.pyc, but /usr/lib64/python2.4/site-packages/Trac-0.12.4-py2.4.egg is being added to sys.path
from pkg_resources import DistributionNotFound, get_distribution

Am looking this one up now.

comment:6 in reply to:  5 Changed 12 years ago by Ryan J Ollos

Replying to anonymous:

Also of note ... when I restart apache I get the following in the error log:

It looks like you have two instances of Trac installed in site-packages.

comment:7 Changed 12 years ago by anonymous

Yes, there were two versions installed in site-packages. Removed the older version. But I still have the problem with the plugin. Same as in the comments from 10/08/12 at 16:43. Still no admin pages. Still not seeing child section in tickets. The .egg is installed. I tried to install it again, but it says it's already installed. Anyone willing to get on Skype and help me out with this?

comment:8 Changed 12 years ago by anonymous

no errors in trac log files or apache log files now. After I install the egg, I restart apache, and I get nothing. Even if I manually expand the .egg (I'm trying anything at this point), restart apache, still doesn't work.

comment:9 Changed 12 years ago by Ryan J Ollos

  • Are you using any other plugins?
  • You should be seeing one of two messages in the log, either Loading or Skipping. I think the latter is an error, but you may need to set the log level to INFO or DEBUG to see the former.

If you don't get one of those two messages in the log, then Trac isn't "picking up" the egg, and you probably have some problem with your python path or other aspect of the environment.

comment:10 Changed 12 years ago by Mark Ryan


Another thing to check is the permissions you are using to access your trac environmnet with. You will only see the admin pages if your user has 'TRAC_ADMIN' privileges, please confirm that this is the case.

As for the examples you give in the description, ticket #1313 is of type 'task' but in your trac.ini, you have explicitly de-activated childtickets for 'task' type tickets.

# 'task' : child tickets are not allowed.
parent.task.allow_child_tickets = false

I don't know what types you have defined in your trac environment, but these need to be configured correctly before you will see the childtickets drop down in any pyrent ticket.

Please get back to me and let me know how you get on ....

Regards Mark

comment:11 Changed 8 years ago by Ryan J Ollos

Resolution: worksforme
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Mark Ryan.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.