Modify

Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#1054 closed defect (fixed)

After Installing TimingAndEstimation and ScrumBurnDownPlugIn Can't Update Existing Tickets

Reported by: swithin@… Owned by: Russ Tyndall
Priority: high Component: TimingAndEstimationPlugin
Severity: blocker Keywords: timing estimation plugin burndown parameter error
Cc: swithin@…, schandler@… Trac Release: 0.10

Description (last modified by Alec Thomas)

I'm running Trac 0.10.3 on Windows w/SQLite db and Python 2.3.

I installed the timingandestimationplugin-0.1.5-py2.3.egg and TracBurndown-01.04.10-py2.3.egg plug-ins, updated the environment/db.

Then I went into the Admin page and turned all check boxes for both new plug-ins.

I could view the Burndown page as well as the Billing And Estimation pages.

When I opened an existing ticket so I could enter some hours, I got the following error after hitting the Submit button. (I also tried merely adding a new comment with no changes to other fields and got the same error).

Python Traceback
Traceback (most recent call last):
  File "C:\Python23\Lib\site-packages\trac\web\main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python23\Lib\site-packages\trac\web\main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\Python23\Lib\site-packages\trac\ticket\web_ui.py", line 279, in process_request
    self._do_save(req, db, ticket)
  File "C:\Python23\Lib\site-packages\trac\ticket\web_ui.py", line 546, in _do_save
    cnum=internal_cnum):
  File "C:\Python23\Lib\site-packages\trac\ticket\model.py", line 262, in save_changes
    listener.ticket_changed(self, comment, author, old_values)
TypeError: ticket_changed() takes exactly 4 arguments (5 given)

Attachments (1)

Trac Plug-Ins.JPG (69.2 KB) - added by anonymous 11 years ago.
Screen shot of plug-ins from the admin page

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by anonymous

Attachment: Trac Plug-Ins.JPG added

Screen shot of plug-ins from the admin page

comment:1 Changed 11 years ago by anonymous

Component: ScrumBurndownPluginTimingAndEstimationPlugin
Owner: changed from Sam Bloomquist to Russ Tyndall

Additional Analysis:

I disabled the Burndown plug-in via the web Admin page, bounced Apache, and the problem still happened.

I then disabled the TimingAndEstimation plug-in via the web Admin page, bounced Apache, and the problem went away.

This leads me to believe that the problem is with the TimingAndEstimation plug-in rather than with the BurnDown plug-in.

comment:2 Changed 11 years ago by anonymous

Keywords: timing estimation plugin burndown parameter error added

comment:3 Changed 11 years ago by anonymous

Cc: swithin@… schandler@… added; anonymous removed

comment:4 Changed 11 years ago by Russ Tyndall

Resolution: fixed
Status: newclosed

The version of trac you are using is incompatable with the old version of the TimingAndEstimationPlugin that you are using. They changed some internal interfaces in trac 10.1 or 10.2. You probably want to instead use the latest revision of the TimingAndEstimationPlugin ([download:timingandestimationplugin version 0.3.6]). You will also need to ensure that the version of sqlite you are using is >=3.2.3

This should hopefully resolve your problem, if not please reopen the ticket, Russ

comment:5 Changed 10 years ago by Alec Thomas

Description: modified (diff)

comment:6 Changed 10 years ago by schandler@…

Bobby, I followed your advice and all is well. Thanks. Perhaps there should be a new Type added called "Question" for issues that end up not being defects nor enhancements.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Russ Tyndall.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.