Modify

Opened 4 years ago

Closed 4 years ago

#10567 closed defect (fixed)

Zombie test catalogs in template management page

Reported by: anonymous Owned by: Roberto Longobardi
Priority: normal Component: TestManagerForTracPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

On the Template Admin page a long list of non existing test catalogs without names is displayed. The only catalogs I really have are the ones that have names. How can I get rid of the zombie catalogs in this list? I'm running Test Manager 1.5.2 on Trac 1.0.1.
Screenshot

Attachments (1)

TestCatalogList.jpg (857.9 KB) - added by marcel.tschanen@… 4 years ago.
Screenshot

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by marcel.tschanen@…

Attachment: TestCatalogList.jpg added

Screenshot

comment:1 Changed 4 years ago by Roberto Longobardi

Status: newassigned

I cannot reproduce this exact situation, but I may have found the problem behind it.

Would you please install the SQLExecutor plugin (form the Test Manager package) and run this query:

select * from testmanager_templates

I expect that you will find several templates with a blank ID (first column in the results). If this is the case, I have already developed a fix. Otherwise, please could you paste the results here?

Ciao, Roberto

comment:2 in reply to:  1 Changed 4 years ago by anonymous

Hi Roberto

In the DB table that creates the link between the test catalogs and the test cases templates we've found many empty records. We manually deleted all empty records, i.e all the ones which don't match the existing test catalog id. After doing so we got an almost proper default test case template per test catalog list.
There is one remaining empty entry which we don't find in the DB. Probably some weird leftover from our upgrading and test manager clearing actions.
With new test catalogs assigning and re-assigning templates to catalogs works fine.

comment:3 Changed 4 years ago by Roberto Longobardi

Fixed in 1.6.1.

comment:4 Changed 4 years ago by Roberto Longobardi

Resolution: fixed
Status: assignedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Roberto Longobardi.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.