Modify

Opened 11 years ago

Closed 10 years ago

#1060 closed defect (fixed)

Calendar Navigation breaks at the end of each month!

Reported by: tag@… Owned by: John Hampton
Priority: high Component: TracBlogPlugin
Severity: normal Keywords: blog
Cc: Trac Release: 0.10

Description

Today http://www.blisted.org/blog?year=2006&month=6, and at the end of any other month with 31 days, navigation to previous months will break due to the fact that it attempts to navigate to this day of the month you've selected. There aren't 31 days in all months, so this will break navigation and result in an error.

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by John Hampton

Status: newassigned

Do you have the traceback in your log?

It's not the 31st, and so I can't reproduce the bug today. And as such, I can't seem to find where exactly the bug is.

If you don't have it, I'll try to remember to take a look at it on the 31st.

comment:2 Changed 10 years ago by John Hampton

Resolution: fixed
Status: assignedclosed

(In [1913])

  • Closes #1060
  • Fixed similar bug when passing in an arbitrary day. If it's too big (ie, 32) it will just default to the last day of the month.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain John Hampton.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.