Modify

Opened 4 years ago

Closed 4 years ago

#10776 closed defect (duplicate)

UnicodeDecodeError: 'utf8' codec can't decode byte 0xd6 in position 39: invalid continuation byte

Reported by: hslee@… Owned by: Herbert Valerio Riedel
Priority: normal Component: GitPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

How to Reproduce

While doing a GET operation on /login, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{}

User agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11

System Information

Trac 0.12.2
Babel 0.9.6 (translations unavailable)
Docutils 0.8.1
Genshi 0.6
GIT 1.7.9.5
mod_python 3.3.1
Pygments 1.4
pysqlite 2.6.0
Python 2.7.3 (default, Aug 1 2012, 05:25:23)
[GCC 4.6.3]
pytz 2011k
setuptools 0.6
SQLite 3.7.9
Subversion 1.6.17 (r1128011)
jQuery 1.4.2

Enabled Plugins

TracGit 0.12.0.5dev

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/api.py", line 332, in pre_process_request
    repo.sync()
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/cache.py", line 242, in sync
    @self.env.with_transaction()
  File "/usr/lib/python2.7/dist-packages/trac/db/api.py", line 77, in transaction_wrapper
    fn(ldb)
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/cache.py", line 271, in do_transaction
    for path, kind, action, bpath, brev in cset.get_changes():
  File "/usr/lib/python2.7/dist-packages/tracext/git/git_fs.py", line 655, in get_changes
    self.repos.git.diff_tree(parent, self.rev, find_renames=True):
  File "/usr/lib/python2.7/dist-packages/tracext/git/PyGIT.py", line 862, in diff_tree
    yield __chg_tuple()
  File "/usr/lib/python2.7/dist-packages/tracext/git/PyGIT.py", line 854, in __chg_tuple
    chg[5] = self._fs_to_unicode(chg[5])
  File "/usr/lib/python2.7/dist-packages/tracext/git/PyGIT.py", line 237, in <lambda>
    self._fs_to_unicode = lambda s: s.decode(git_fs_encoding)
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xd6 in position 39: invalid continuation byte

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by anonymous

Component: SELECT A HACKGitPlugin
Owner: changed from anonymous to Herbert Valerio Riedel
Trac Release: 0.12

comment:2 Changed 4 years ago by Ryan J Ollos

Currently there is no maintainer for the GitPlugin. The best way to get support for Git is to upgrade to Trac 1.0, and you will find that the plugin has been integrated into the core.

comment:3 Changed 4 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #9960.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Herbert Valerio Riedel.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.