Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#10973 closed defect (worksforme)

ProgressMeterMacro canot link to a milestones that contains a blank

Reported by: anonymous Owned by: Andrej Tokarčík
Priority: normal Component: ProgressMeterMacro
Severity: normal Keywords: needinfo
Cc: Trac Release: 0.12

Description

The following displays the expected progress-bar as desired, however when clicking below on the number of active ticktes (Closed, Active, Total) the query does not return any tickets. The blank in "My Milestones" is not properly interpreted.

[[ProgressMeter(milestone=My Milestone)]]

Attachments (1)

MyMilestones.png (3.0 KB) - added by Ryan J Ollos 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by Ryan J Ollos

Attachment: MyMilestones.png added

comment:1 Changed 4 years ago by Ryan J Ollos

Keywords: needinfo added

I can't reproduce with the latest 0.12-branch version of ProgressMeterMacro (r11720) and Trac 0.12.

The links below the Progress bar have the following relative URLs:

  • closed: /query?status=closed&group=resolution&milestone=My+Milestone&order=priority
  • active: /query?status=assigned&status=new&status=accepted&status=reopened&group=status&order=priority&milestone=My+Milestone
  • Total: /query?group=status&order=priority&milestone=My+Milestone

I tested in a new environment with 1 open and 1 closed ticket associated with the milestone. I used the same macro call: [[ProgressMeter(milestone=My Milestone)]]. Here is the screen capture:

Any idea of what the differences might be between your case and mine?

comment:2 Changed 4 years ago by Ryan J Ollos

Resolution: worksforme
Status: newclosed

Closing since there has been no feedback. Please reopen if you can provide more information and wish to continue working on debugging the issue.

Side note: please also consider registering for an account so that you'll receive email updates for the ticket.

comment:3 Changed 4 years ago by amessagetoyourudi@…

Yes, it is working, my fault ! I didn't have the latest version installed. Sorry for the inconveniance !

Rudi

comment:4 Changed 4 years ago by Ryan J Ollos

Glad it is working for you. Thank you for following up, it's nice to get some assurance that there is not a bug :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Andrej Tokarčík.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.