Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11060 closed defect (duplicate)

AnnouncerPlugin doesn't honor always_cc and always_bcc

Reported by: vanton@… Owned by: Steffen Hoffmann
Priority: normal Component: AnnouncerPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

I set always_cc and always_bcc in trac.ini like that:

email_always_cc = mail1@cytech.gr

and it seems at the logs that it uses them:

2013-05-08 10:47:13,004 Trac[api] DEBUG: AnnouncementSystem has found the following subscriptions: [vagelis antoniadis(authenticated) via email]
2013-05-08 10:47:13,004 Trac[mail] DEBUG: EmailDistributor has found the following formats capable of handling 'email' of 'ticket': text/html, text/plain
2013-05-08 10:47:13,006 Trac[mail] DEBUG: EmailDistributor found the address 'vanton@cytech.gr' for 'vagelis antoniadis (authenticated)' via: SpecifiedEmailResolver
2013-05-08 10:47:13,006 Trac[mail] DEBUG: EmailDistributor expected local delivery for vagelis antoniadis to: vanton@cytech.gr
2013-05-08 10:47:13,006 Trac[mail] DEBUG: EmailDistributor is sending event as 'text/html' to: vanton@cytech.gr
2013-05-08 10:47:13,007 Trac[mail] DEBUG: All email recipients: [u'vanton@cytech.gr']
2013-05-08 10:47:13,055 Trac[email_decorators] DEBUG: StaticEmailDecorator added 'dev_team' because of rule: email_always_cc
2013-05-08 10:47:13,055 Trac[email_decorators] DEBUG: StaticEmailDecorator added 'mail1@cytech.gr' because of rule: email_always_bcc
2013-05-08 10:47:13,122 Trac[mail] DEBUG: EmailDistributor took 0.06 seconds to send.
2013-05-08 10:47:13,122 Trac[api] DEBUG: AnnouncementSystem sent event in 0.12 seconds.

But at the mail server's logs it only sends email to the recipient of the TO field and nothing to the ones at CC and BCC fields.

Any ideas?

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by Ryan J Ollos

Which version of Trac are you using, and which version of AnnouncerPlugin have you installed?

comment:2 Changed 4 years ago by vanton@…

I use Trac 1.0.1 and TracAnnouncer 1.0dev-r0

comment:3 Changed 4 years ago by Ryan J Ollos

Trac Release: 1.0

Is it safe to assume that you have the latest TracAnnouncer (r12503)? The -r0 is appended when checking-out with a VCS other than SVN, I think.

Could you post a sanitized version of your [announcer] section from trac.ini?

comment:4 Changed 4 years ago by Steffen Hoffmann

Resolution: duplicate
Status: newclosed

Thanks for stepping in that fast, but sorry, there's no need to explain more here. The issue is clear, see #10676.

Thanks for taking your time to report, but follow-up on the original report as required, please.

comment:5 Changed 4 years ago by Ryan J Ollos

Thanks, I had thought this issue sounded familiar.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.