Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11210 closed enhancement (duplicate)

Trac 1.0 Support

Reported by: chris Owned by: Ryan J Ollos
Priority: normal Component: FlexibleReporterNotificationPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

I've updated the code so it works with Trac 1.0.

Attachments (1)

api.py (2.3 KB) - added by chris 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by chris

Attachment: api.py added

comment:1 Changed 4 years ago by Ryan J Ollos

Duplicate of #7554.

comment:2 Changed 4 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

I used some of the ideas in api.py to prepare the fix for #7554. Please test it out and report back if you can.

comment:3 Changed 4 years ago by Ryan J Ollos

In 13701:

Complete rework of plugin, using ideas from #11210 in the patch by chris-at. Fixes #7554, Refs #8821, #11210.

Note that only one instance of the reporter in to_recipients is removed. So for instance, if the reporter is also the owner and always_notify_owner is True, then the reporter will still receive a notification.

This has been lightly tested, so please report back if you find any issues.

comment:4 Changed 4 years ago by Ryan J Ollos

Owner: changed from CStrac to Ryan J Ollos

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.